summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJohannes Matheis <jomat+alpinebuild@jmt.gr>2014-11-05 12:26:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-11-13 07:16:59 +0000
commita772d63f7a1623a9c093ec0d41d56b63744ab7e2 (patch)
tree6b291fd3f7ab601b5658f8c783b32b554fcb17d1 /testing
parent912533bae401728c4d829cb74626baefbcefb90d (diff)
downloadaports-a772d63f7a1623a9c093ec0d41d56b63744ab7e2.tar.bz2
aports-a772d63f7a1623a9c093ec0d41d56b63744ab7e2.tar.xz
testing/jq: new aport
http://stedolan.github.io/jq/ A lightweight and flexible command-line JSON processor
Diffstat (limited to 'testing')
-rw-r--r--testing/jq/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/jq/APKBUILD b/testing/jq/APKBUILD
new file mode 100644
index 000000000..ec1206009
--- /dev/null
+++ b/testing/jq/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Johannes Matheis <jomat+alpinebuild@jmt.gr>
+# Maintainer: Johannes Matheis <jomat+alpinebuild@jmt.gr>
+pkgname=jq
+pkgver=1.4
+pkgrel=0
+pkgdesc="A lightweight and flexible command-line JSON processor"
+url="http://stedolan.github.io/jq/"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc $pkgname-dev"
+source="http://stedolan.github.io/jq/download/source/${pkgname}-${pkgver}.tar.gz"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr --disable-docs
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" prefix=/usr install
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="e3c75a4f805bb5342c9f4b3603fb248f jq-1.4.tar.gz"
+sha256sums="998c41babeb57b4304e65b4eb73094279b3ab1e63801b6b4bddd487ce009b39d jq-1.4.tar.gz"
+sha512sums="02e601b713a3249bcfe5373153dff38a63bf504895181ca3f691dbf033b407373a9c5880001bbd1954123cdf89f4fe75e2a5168e7a7cf13b3f7355dc18f92458 jq-1.4.tar.gz"