summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2009-06-10 08:15:46 +0000
committerLeonardo Arena <rnalrd@gmail.com>2009-06-10 08:15:46 +0000
commitb6f220818cfa4c966335075b752fb039b2d50faf (patch)
treef6e460c8f9bffcb47031eaa36e89d01381ca2eb4 /testing
parent4fb804f0ce12b6120d7dc9de8ab92b6e355ad905 (diff)
downloadaports-b6f220818cfa4c966335075b752fb039b2d50faf.tar.bz2
aports-b6f220818cfa4c966335075b752fb039b2d50faf.tar.xz
testing/perl-time-date: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-time-date/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/perl-time-date/APKBUILD b/testing/perl-time-date/APKBUILD
new file mode 100644
index 000000000..1c02dfe16
--- /dev/null
+++ b/testing/perl-time-date/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Leonardo Arena <rnalrd@gmail.com>
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname=perl-time-date
+_realname=TimeDate
+pkgver=1.16
+pkgrel=0
+pkgdesc="Date formating subroutines"
+url="http://search.cpan.org/~gbarr/TimeDate-1.16/"
+license="Unknown"
+depends="perl"
+makedepends="perl-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/G/GB/GBARR/$_realname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$_realname-$pkgver"
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ rm $pkgdir/usr/lib/perl5/5.10.0/i686-linux/perllocal.pod
+}
+
+md5sums="b3cc35a7cabd106ac8829d2f2ff4bd9d TimeDate-1.16.tar.gz"