summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-11-03 16:27:59 +0200
committerTimo Teräs <timo.teras@iki.fi>2014-11-03 16:27:59 +0200
commitcd841eaf0778a9b2732519507a59dd1cdc1a9822 (patch)
treeb02b04941af945277c4c6e6f1b518aae62cc6a7a /testing
parent2a5c968bee88db6fad68c04df1733e2ff29d4419 (diff)
downloadaports-cd841eaf0778a9b2732519507a59dd1cdc1a9822.tar.bz2
aports-cd841eaf0778a9b2732519507a59dd1cdc1a9822.tar.xz
main/libfetch: move from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/libfetch/APKBUILD30
-rw-r--r--testing/libfetch/Makefile93
2 files changed, 0 insertions, 123 deletions
diff --git a/testing/libfetch/APKBUILD b/testing/libfetch/APKBUILD
deleted file mode 100644
index fcd925cb1..000000000
--- a/testing/libfetch/APKBUILD
+++ /dev/null
@@ -1,30 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=libfetch
-pkgver=2.33
-pkgrel=0
-pkgdesc="URL based download library"
-url="http://cvsweb.netbsd.org/bsdweb.cgi/pkgsrc/net/libfetch/"
-arch="all"
-license="BSD"
-depends=
-makedepends="openssl-dev"
-subpackages="$pkgname-dev $pkgname-doc"
-source="Makefile
- ftp://ftp.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cp "$srcdir"/Makefile "$_builddir"
-}
-
-build () {
- cd "$_builddir"
- make
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR=$pkgdir install
-}
-md5sums="cf18907a75c67f543b1173d7f87830af Makefile
-a176b94f7f30344ef8a71c047ca2136b libfetch-2.33.tar.gz"
diff --git a/testing/libfetch/Makefile b/testing/libfetch/Makefile
deleted file mode 100644
index 9bc8c116d..000000000
--- a/testing/libfetch/Makefile
+++ /dev/null
@@ -1,93 +0,0 @@
-prefix = /usr
-DESTDIR =
-DEBUG = false
-FETCH_WITH_INET6 = true
-FETCH_WITH_OPENSSL = true
-FETCH_WITH_LFS = true
-
-WARNINGS = -Wall -Wstrict-prototypes -Wsign-compare -Wchar-subscripts \
- -Wpointer-arith -Wcast-align -Wsign-compare
-CFLAGS += -O2 -pipe -I. -fPIC $(WARNINGS)
-
-
-CFLAGS += -DFTP_COMBINE_CWDS -DNETBSD
-
-ifeq ($(strip $(FETCH_WITH_LFS)), true)
-CFLAGS+= -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGE_FILES
-endif
-
-ifeq ($(strip $(FETCH_WITH_INET6)), true)
-CFLAGS+= -DINET6
-endif
-
-ifeq ($(strip $(FETCH_WITH_OPENSSL)), true)
-CFLAGS+= -DWITH_SSL
-LDFLAGS= -lssl -lcrypto
-endif
-
-ifeq ($(strip $(DEBUG)), true)
-CFLAGS += -g -DDEBUG
-else
-CFLAGS += -UDEBUG
-endif
-
-CC = gcc
-LD = gcc
-AR = ar
-RANLIB = ranlib
-INSTALL = install -c -D
-
-OBJS= fetch.o common.o ftp.o http.o file.o
-INCS= fetch.h common.h
-GEN = ftperr.h httperr.h
-MAN = libdownload.3
-
-#pretty print!
-E = @echo
-Q = @
-
-all: libfetch.so libfetch.a
- $(E) " built with: " $(CFLAGS)
-.PHONY: all
-
-%.o: %.c $(INCS) $(GEN)
- $(E) " compile " $@
- $(Q) $(CC) $(CFLAGS) -c $<
-
-ftperr.h: ftp.errors
- $(E) " generate " $@
- $(Q) ./errlist.sh ftp_errlist FTP ftp.errors > $@
-
-httperr.h: http.errors
- $(E) " generate " $@
- $(Q) ./errlist.sh http_errlist HTTP http.errors > $@
-
-libfetch.so: $(GEN) $(INCS) $(OBJS)
- $(E) " build " $@
- $(Q) rm -f $@
- $(Q) $(LD) $(LDFLAGS) *.o -shared -o $@
-
-libfetch.a: $(GEN) $(INCS) $(OBJS)
- $(E) " build " $@
- $(Q) rm -f $@
- $(Q) $(AR) rcs $@ *.o
- $(Q) $(RANLIB) $@
-
-clean:
- $(E) " clean "
- $(Q) rm -f libfetch.so libfetch.a *.o $(GEN)
-.PHONY: clean
-
-install: all
- $(Q) $(INSTALL) -m 755 libfetch.so $(DESTDIR)$(prefix)/lib/libfetch.so
- $(Q) $(INSTALL) -m 644 libfetch.a $(DESTDIR)$(prefix)/lib/libfetch.a
- $(Q) $(INSTALL) -m 644 fetch.h $(DESTDIR)$(prefix)/include/fetch.h
- $(Q) $(INSTALL) -m 644 fetch.3 $(DESTDIR)$(prefix)/share/man/man3/fetch.3
-.PHONY: install
-
-uninstall:
- $(Q) rm -f $(DESTDIR)$(prefix)/lib/libfetch.so
- $(Q) rm -f $(DESTDIR)$(prefix)/lib/libfetch.a
- $(Q) rm -f $(DESTDIR)$(prefix)/include/fetch.h
- $(Q) rm -f $(DESTDIR)$(prefix)/share/man/man3/fetch.3
-.PHONY: uninstall