summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman@gmail.com>2011-03-01 23:17:57 -0500
committerKiyoshi Aman <kiyoshi.aman@gmail.com>2011-03-01 23:18:27 -0500
commit4d9e80d34f6b4e6aa520b8e92c3a0b613b4e547e (patch)
tree61beb5a1e3966479acb48b04f4942c12e78cab0f /testing
parent88c77025827520715e351144f8fd3e2249453720 (diff)
downloadaports-4d9e80d34f6b4e6aa520b8e92c3a0b613b4e547e.tar.bz2
aports-4d9e80d34f6b4e6aa520b8e92c3a0b613b4e547e.tar.xz
testing/apache-mod-fcgid: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/apache-mod-fcgid/APKBUILD34
-rw-r--r--testing/apache-mod-fcgid/mod_fcgid.conf9
2 files changed, 43 insertions, 0 deletions
diff --git a/testing/apache-mod-fcgid/APKBUILD b/testing/apache-mod-fcgid/APKBUILD
new file mode 100644
index 000000000..7f9c1d7c6
--- /dev/null
+++ b/testing/apache-mod-fcgid/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer:
+pkgname=apache-mod-fcgid
+pkgver=2.3.6
+pkgrel=0
+pkgdesc="FastCGI module for Apache 2.2"
+url="http://httpd.apache.org/mod_fcgid/"
+arch="all"
+license="Apache"
+depends=
+makedepends="apache2-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://apache.cyberuse.com//httpd/mod_fcgid/mod_fcgid-$pkgver.tar.bz2
+ mod_fcgid.conf
+ "
+
+_builddir="$srcdir/mod_fcgid-$pkgver"
+
+build() {
+ cd "$_builddir"
+ ./configure.apxs || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ mkdir "$pkgdir"/etc/apache2/conf.d/ || return 1
+ install -m644 "$srcdir"/mod_fcgid.conf "$pkgdir"/etc/apache2/conf.d/ || return 1
+}
+
+md5sums="30ee138f3f0eb1c55303400748f128a2 mod_fcgid-2.3.6.tar.bz2
+df658a483cf016112d75bbd1d92d7fb0 mod_fcgid.conf"
diff --git a/testing/apache-mod-fcgid/mod_fcgid.conf b/testing/apache-mod-fcgid/mod_fcgid.conf
new file mode 100644
index 000000000..01529b068
--- /dev/null
+++ b/testing/apache-mod-fcgid/mod_fcgid.conf
@@ -0,0 +1,9 @@
+<IfModule mod_fcgid.c>
+ Alias /fcgi-bin/ "/usr/lib/fcgi-bin/"
+ <Location /fcgi-bin>
+ SetHandler fcgid-script
+ Options +ExecCGI
+ Order allow,deny
+ Allow from all
+ </Location>
+</IfModule>