summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-04-21 14:32:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-04-21 14:32:02 +0000
commit78834aed72ecf339da0d48c94c5329af7ea35e6c (patch)
treee99a0e20ecb97c27e54ae4e8774f709f68db4f42 /testing
parent28d3a986488900f1d15ec23d02f6f264bc8fe692 (diff)
downloadaports-78834aed72ecf339da0d48c94c5329af7ea35e6c.tar.bz2
aports-78834aed72ecf339da0d48c94c5329af7ea35e6c.tar.xz
testing/iscsi-scst: new aport
ISCSI target for SCST - userspace tools http://iscsi-scst.sourceforge.net/
Diffstat (limited to 'testing')
-rw-r--r--testing/iscsi-scst/APKBUILD39
-rw-r--r--testing/iscsi-scst/iscsi-scst.initd23
2 files changed, 62 insertions, 0 deletions
diff --git a/testing/iscsi-scst/APKBUILD b/testing/iscsi-scst/APKBUILD
new file mode 100644
index 000000000..9f373ea59
--- /dev/null
+++ b/testing/iscsi-scst/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Carlo Landmeter
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+
+pkgname=iscsi-scst
+pkgver=1.0.1.1
+pkgrel=0
+pkgdesc="ISCSI target for SCST - userspace tools"
+url="http://iscsi-scst.sourceforge.net/"
+license="GPL-2"
+depends=
+install=
+makedepends="openssl-dev"
+subpackages=
+source="http://downloads.sourceforge.net/scst/$pkgname-$pkgver.tar.gz
+ iscsi-scst.initd
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ # we need the headre file. fix dependency in makefile
+ sed -i -e 's/^\(progs:.*\)/\1 include\/iscsi_scst_itf_ver.h/' Makefile
+}
+
+build() {
+ cd "$_builddir"
+ make progs
+}
+
+package() {
+ cd "$_builddir"
+ # make install is broken
+ install -D usr/iscsi-scstd "$pkgdir"/usr/sbin/iscsi-scstd
+ install -D usr/iscsi-scst-adm "$pkgdir"/iscsi-scst-adm
+ install -D -m 755 "$srcdir"/iscsi-scst.initd "$pkgdir"/etc/init.d/iscsi-scst
+}
+
+md5sums="56109c01e3d4421a36d6f47efa1fb0d5 iscsi-scst-1.0.1.1.tar.gz
+3132fae1ec2f9bcc72476d9e9f36d326 iscsi-scst.initd"
diff --git a/testing/iscsi-scst/iscsi-scst.initd b/testing/iscsi-scst/iscsi-scst.initd
new file mode 100644
index 000000000..4d4cd76b5
--- /dev/null
+++ b/testing/iscsi-scst/iscsi-scst.initd
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+#
+# Start the iSCSI-SCST Target.
+#
+
+depend() {
+ need net
+ afer firewall
+}
+
+start() {
+ modprobe -q crc32c
+ modprobe -q iscsi-scst
+ ebegin "Starting iscsi-scstd"
+ start-stop-daemon --start --exec /usr/sbin/iscsi-scstd
+ eend 0
+}
+
+stop() {
+ ebegin "Stopping iscsi-scstd"
+ start-stop-daemon --stop --exec /usr/sbin/iscsi-scstd
+ eend 0
+}