summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorKiyoshi Aman <aphrael@alpinelinux.org>2011-11-26 21:33:55 -0500
committerKiyoshi Aman <aphrael@alpinelinux.org>2011-12-04 22:09:36 -0500
commit93415221b8ac0ec73382e350c0c90a8e80af25a9 (patch)
tree9ba8b8613a22953cc60dd1ab22c7d265b4e4e72c /testing
parentf66114b5b3448d26936a1e0e202fe043432d0af3 (diff)
downloadaports-93415221b8ac0ec73382e350c0c90a8e80af25a9.tar.bz2
aports-93415221b8ac0ec73382e350c0c90a8e80af25a9.tar.xz
testing/perl-test-refcount: new APKBUILD
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-test-refcount/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/perl-test-refcount/APKBUILD b/testing/perl-test-refcount/APKBUILD
new file mode 100644
index 000000000..d4d71f1e7
--- /dev/null
+++ b/testing/perl-test-refcount/APKBUILD
@@ -0,0 +1,38 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+pkgname=perl-test-refcount
+_pkgreal=Test-Refcount
+pkgver=0.07
+pkgrel=0
+pkgdesc="assert reference counts on objects"
+url="http://search.cpan.org/dist/Test-Refcount/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ perl Build.PL installdirs=vendor || return 1
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ ./Build && ./Build test
+}
+
+package() {
+ cd "$_builddir"
+ ./Build install destdir="$pkgdir" || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="0a78c2f25e91c27baf0f71118a970245 Test-Refcount-0.07.tar.gz"