summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-08-31 17:56:22 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-31 17:56:22 +0000
commitee0c261f2c61da6010f1edac48262c337546e82d (patch)
tree0cb8feb727554e4ae4e782a86d4da0ab10f0a923 /testing
parentb8ebe7fe4fc69c45072580f7f2d367f12f427e4d (diff)
downloadaports-ee0c261f2c61da6010f1edac48262c337546e82d.tar.bz2
aports-ee0c261f2c61da6010f1edac48262c337546e82d.tar.xz
testing/lua-yaml: new aport
LibYaml binding for Lua http://yaml.luaforge.net
Diffstat (limited to 'testing')
-rw-r--r--testing/lua-yaml/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/lua-yaml/APKBUILD b/testing/lua-yaml/APKBUILD
new file mode 100644
index 000000000..70aaa542a
--- /dev/null
+++ b/testing/lua-yaml/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-yaml
+pkgver=0.2
+pkgrel=0
+pkgdesc="LibYaml binding for Lua"
+url="http://yaml.luaforge.net"
+arch="all"
+license="MIT"
+depends=""
+makedepends="yaml-dev"
+install=""
+subpackages=""
+source="http://luaforge.net/frs/download.php/4284/yaml-$pkgver.tar.gz"
+
+_builddir="$srcdir"/yaml-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -d "$pkgdir"/usr/lib/lua/5.1
+ make PREFIX="$pkgdir"/usr install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="18c25a2a6609b2862e3485952cf73634 yaml-0.2.tar.gz"