summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2014-11-23 15:02:23 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2014-11-27 07:54:00 +0000
commit2d1f8fa08e25084a3e333262211e94b7c6689259 (patch)
treec39c76cd13c84ed35180904ea071a8a0a2d5f3b5 /testing
parentc59e61131c8c1f1dfea790de80f0d25170304a29 (diff)
downloadaports-2d1f8fa08e25084a3e333262211e94b7c6689259.tar.bz2
aports-2d1f8fa08e25084a3e333262211e94b7c6689259.tar.xz
/testing/py-bottle-api: new aport
Bottle JSON Web API https://github.com/tomotaka/bottle-api
Diffstat (limited to 'testing')
-rw-r--r--testing/py-bottle-api/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-bottle-api/APKBUILD b/testing/py-bottle-api/APKBUILD
new file mode 100644
index 000000000..a7221309a
--- /dev/null
+++ b/testing/py-bottle-api/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-bottle-api
+_pkgname=bottle-api
+pkgver=0.0.2
+pkgrel=0
+pkgdesc="Bottle JSON Web API"
+url="https://github.com/tomotaka/bottle-api"
+arch="noarch"
+license="MIT"
+depends="python py-bottle"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="6b064de05dd43c0d2373ea1c4e1355f4 bottle-api-0.0.2.tar.gz"
+sha256sums="1e8c5a6921d639b376ade65d5d60a173353f8587f5e38a6653b951a413caedf8 bottle-api-0.0.2.tar.gz"
+sha512sums="d66e33fb5b721bfab7c968b394b17d3953ff0290b3db384002675ab116a7051c7fb6ee5d35285bf2adc224fe22d80668c6339e689458e073bbbecb393384582e bottle-api-0.0.2.tar.gz"