summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2013-01-07 23:06:24 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2013-01-07 23:12:43 +0100
commit3348f27438d8520bbc8d8acd8b748de6ea828989 (patch)
tree41727e22dea4bf7417b7f448cc948c182c0859f1 /testing
parente53728423351a0f40e3e699537eaabbda05b77a9 (diff)
downloadaports-3348f27438d8520bbc8d8acd8b748de6ea828989.tar.bz2
aports-3348f27438d8520bbc8d8acd8b748de6ea828989.tar.xz
testing/crystalhd-git-grsec: move to main
Diffstat (limited to 'testing')
-rw-r--r--testing/crystalhd-git-grsec/APKBUILD109
-rw-r--r--testing/crystalhd-git-grsec/crystalhd-use_8_DMA_buffers-0.1.patch11
2 files changed, 0 insertions, 120 deletions
diff --git a/testing/crystalhd-git-grsec/APKBUILD b/testing/crystalhd-git-grsec/APKBUILD
deleted file mode 100644
index 0ab1d5ea4..000000000
--- a/testing/crystalhd-git-grsec/APKBUILD
+++ /dev/null
@@ -1,109 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer:
-
-_flavor=${FLAVOR:-grsec}
-_realname=crystalhd-git
-_name=$_realname-$_flavor
-
-_kpkg=linux-$_flavor
-_kver=3.6.11
-_kpkgrel=1
-
-_mypkgrel=0
-_date=20121126
-
-# source the kernel version
-if [ -f ../../main/linux-$_flavor/APKBUILD ]; then
- . ../../main/linux-$_flavor/APKBUILD
- [ "$_kver" != "$pkgver" ] && die "$_name: Please update _kver to $pkgver"
- [ "$_kpkgrel" != "$pkgrel" ] && die "$_name: Please update _kpkgrel to $pkgrel"
-fi
-
-_kernelver=$_kver-r$_kpkgrel
-_abi_release=$_kver-${_flavor}
-
-pkgname=$_name
-pkgver=20121205
-pkgrel=$(($_kpkgrel + $_mypkgrel))
-pkgdesc="Broadcom CrystalHD kernel driver"
-url="http://git.linuxtv.org/jarod/crystalhd.git"
-arch="all"
-license="GPL2"
-depends=""
-depends_dev=""
-makedepends="$depends_dev automake autoconf linux-$_flavor-dev=$_kernelver"
-install=""
-subpackages="$pkgname-dev libcrystalhd"
-source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-${_date}.tar.gz
- crystalhd-use_8_DMA_buffers-0.1.patch"
-
-_giturl="git://linuxtv.org/jarod/crystalhd.git"
-_upload="dev.alpinelinux.org:/archive/$pkgname/"
-_libdir="$srcdir/$pkgname-$_date/linux_lib/libcrystalhd"
-_kerdir="$srcdir/$pkgname-$_date/driver/linux"
-_builddir="$srcdir/$pkgname-$_date"
-
-snapshot() {
- local _date=$(date +%Y%m%d)
- local _pkg=$pkgname-$_date.tar.gz
- mkdir -p "$srcdir"
- cd "$srcdir"
- msg "Creating snapshot: $_pkg"
- rm -rf ${_giturl##*/}
- git clone --depth=1 --bare $_giturl || return 1
- git --git-dir ${_giturl##*/} archive -o $_pkg \
- --prefix=$pkgname-$_date/ HEAD \
- || return 1
- msg "Uploading to $_upload"
- rsync -Lave ssh $_pkg $_upload || return 1
- cd "$startdir"
- sed -i -e "s/^pkgver=.*/pkgver=$_date/" \
- APKBUILD || return 1
- abuild checksum
-}
-
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_libdir"
- msg "building library"
- make || return 1
- cd "$_kerdir"
- msg "building module"
- export GCC_SPECS=/usr/share/gcc/hardenednopie.specs
- autoconf
- ./configure --prefix=/usr \
- --with-kernel-path=/usr/src/linux-headers-${_abi_release}
- make || return 1
-}
-
-package() {
- cd "$_kerdir"
- mkdir -p "$pkgdir"/lib/modules/"$_abi_release"/kernel/drivers/video/broadcom
- install -m 0644 crystalhd.ko \
- "$pkgdir"/lib/modules/"$_abi_release"/kernel/drivers/video/broadcom
- cd "$_libdir"
- make DESTDIR="$pkgdir" install || return 1
-}
-
-dev() {
- default_dev
-}
-
-libcrystalhd() {
- pkgdesc="Broadcom CrystalHD kernel library"
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/lib \
- "$subpkgdir"/usr/
-}
-
-md5sums="3459e3b206702cea539f09fb9abbb4f8 crystalhd-git-grsec-20121126.tar.gz
-e617ef3212dd46749d61247b5cbb51bd crystalhd-use_8_DMA_buffers-0.1.patch"
diff --git a/testing/crystalhd-git-grsec/crystalhd-use_8_DMA_buffers-0.1.patch b/testing/crystalhd-git-grsec/crystalhd-use_8_DMA_buffers-0.1.patch
deleted file mode 100644
index 1b9150ea7..000000000
--- a/testing/crystalhd-git-grsec/crystalhd-use_8_DMA_buffers-0.1.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/include/bc_dts_glob_lnx.h
-+++ b/include/bc_dts_glob_lnx.h
-@@ -76,7 +76,7 @@
- BC_LINK_MAX_OPENS = 3, /* Maximum simultaneous opens*/
- BC_LINK_MAX_SGLS = 1024, /* Maximum SG elements 4M/4K */
- BC_TX_LIST_CNT = 2, /* Max Tx DMA Rings */
-- BC_RX_LIST_CNT = 16, /* Max Rx DMA Rings*/
-+ BC_RX_LIST_CNT = 8, /* Max Rx DMA Rings*/
- BC_PROC_OUTPUT_TIMEOUT = 2000, /* Milliseconds */
- BC_INFIFO_THRESHOLD = 0x10000,
- };