summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2012-07-17 12:19:21 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2012-07-17 12:21:22 +0000
commitf189da3234c4a015fa7050dc05cb8e17207897e2 (patch)
tree9be0601dbd764db5fdf2a224cddf05048fbeda85 /testing
parentd39a0961cd6f133e3a0b61991e82b8e6595ab55d (diff)
downloadaports-f189da3234c4a015fa7050dc05cb8e17207897e2.tar.bz2
aports-f189da3234c4a015fa7050dc05cb8e17207897e2.tar.xz
testing/open-lldp: new aport
A Link Layer Discovery Protocol Agent Daemon
Diffstat (limited to 'testing')
-rw-r--r--testing/open-lldp/APKBUILD47
-rw-r--r--testing/open-lldp/open-lldp.confd2
-rwxr-xr-xtesting/open-lldp/open-lldp.initd24
3 files changed, 73 insertions, 0 deletions
diff --git a/testing/open-lldp/APKBUILD b/testing/open-lldp/APKBUILD
new file mode 100644
index 000000000..b2b0c6ce1
--- /dev/null
+++ b/testing/open-lldp/APKBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=open-lldp
+_realname=lldpad
+pkgver=0.9.38
+pkgrel=0
+pkgdesc="Open Source implementation of the IEEE standard 802.1AB Link Layer Discovery Protocol (LLDP)"
+url="http://www.open-lldp.org"
+arch="all"
+license="GPL"
+depends=
+makedepends=
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://www.open-lldp.org/open-lldp/downloads/$_realname-$pkgver.tar.gz
+ $pkgname.initd
+ $pkgname.confd"
+
+_builddir="$srcdir"/$_realname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ sed -i 's/ln -T -s/ln -s/' Makefile.am || exit 1
+ sed -i 's/ln -T -s/ln -s/' Makefile.in || exit 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ mkdir -p "$pkgdir"/usr/include/dcbd
+ # ln -s /usr/include/lldpad "$pkgdir"/usr/include/dcbd
+ ln -s /usr/include/lldpad/lldp_dcbx_cmds.h "$pkgdir"/usr/include/dcbd/clif_cmds.h
+ install -m755 -D ../../$pkgname.initd "$pkgdir"/etc/init.d/$_realname
+ install -m644 -D ../../$pkgname.confd "$pkgdir"/etc/conf.d/$_realname
+}
+
+md5sums="a55178979b523c02d0bb90bb36f3a693 lldpad-0.9.38.tar.gz
+4d226f4520fec36afee8e6b6eebf46f1 open-lldp.initd
+a1d2e351028d39193fc0a3466ba4db33 open-lldp.confd"
diff --git a/testing/open-lldp/open-lldp.confd b/testing/open-lldp/open-lldp.confd
new file mode 100644
index 000000000..a4d4b1de8
--- /dev/null
+++ b/testing/open-lldp/open-lldp.confd
@@ -0,0 +1,2 @@
+# Remove existing pid file at startup
+OPTS="-d -f /etc/lldpad.conf"
diff --git a/testing/open-lldp/open-lldp.initd b/testing/open-lldp/open-lldp.initd
new file mode 100755
index 000000000..ed9807d51
--- /dev/null
+++ b/testing/open-lldp/open-lldp.initd
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+
+NAME="lldpad"
+DAEMON="/usr/sbin/$NAME"
+pidfile=/var/run/$NAME.pid
+
+depend() {
+ need net
+ after firewall
+}
+
+start() {
+ ebegin "Starting ${NAME}"
+ start-stop-daemon --start --quiet --pidfile ${pidfile} \
+ --exec ${DAEMON} -- ${OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${NAME}"
+ start-stop-daemon --stop --exec ${DAEMON}
+ eend $?
+}
+