summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-08-11 19:27:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-08-11 19:27:23 +0000
commitf810fe0c4dd9fb532c53c15837854fc6880ba553 (patch)
treeef264b38fec57e1ad6e5b666aedf3a7cceb518f9 /testing
parent5af1e9df846236fa1ce776162f3f7bd7a0cefb17 (diff)
downloadaports-f810fe0c4dd9fb532c53c15837854fc6880ba553.tar.bz2
aports-f810fe0c4dd9fb532c53c15837854fc6880ba553.tar.xz
testing/conky: new aport
An advanced, highly configurable system monitor for X based on torsmo http://conky.sourceforge.net/
Diffstat (limited to 'testing')
-rw-r--r--testing/conky/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/conky/APKBUILD b/testing/conky/APKBUILD
new file mode 100644
index 000000000..6f3514edc
--- /dev/null
+++ b/testing/conky/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=conky
+pkgver=1.8.0
+pkgrel=0
+pkgdesc="An advanced, highly configurable system monitor for X based on torsmo"
+url="http://conky.sourceforge.net/"
+license="custom"
+depends=""
+makedepends="pkgconfig alsa-lib-dev libxml2-dev curl-dev wireless-tools-dev
+ libxft-dev glib-dev libxdamage-dev libxext-dev imlib2-dev lua-dev
+ "
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/project/conky/conky/$pkgver/conky-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build ()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-wlan \
+ --enable-rss \
+ --enable-ibm \
+ --enable-imlib2 \
+ --enable-lua \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+
+md5sums="494cbaf1108cfdb977fc80454d9b13e2 conky-1.8.0.tar.bz2"