summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-10-24 19:50:11 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-03 14:49:18 -0600
commit632de8793c3aea6a3c80dcc44aa42b6c690f5138 (patch)
treedaf4006ddef7bd7b02e42db55c14b94eb997b73b /testing
parentaa0a17517c0f9c4a76fee6457b8ad415b35e362c (diff)
downloadaports-632de8793c3aea6a3c80dcc44aa42b6c690f5138.tar.bz2
aports-632de8793c3aea6a3c80dcc44aa42b6c690f5138.tar.xz
Initial APKBUILD for tftpy
Package description: Tftpy is a TFTP library for the Python programming language. It includes client and server classes, with sample implementations. Hooks are included for easy inclusion in a UI for populating progress indicators. http://tftpy.sourceforge.net/
Diffstat (limited to 'testing')
-rw-r--r--testing/tftpy/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/tftpy/APKBUILD b/testing/tftpy/APKBUILD
new file mode 100644
index 000000000..c0f2766da
--- /dev/null
+++ b/testing/tftpy/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=tftpy
+pkgver=0.6.0
+pkgrel=0
+pkgdesc="A Pure Python TFTP Protocol Implementation"
+url="http://tftpy.sourceforge.net/"
+arch="noarch"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages=""
+source="http://downloads.sourceforge.net/tftpy/tftpy-$pkgver.tar.gz"
+_builddir="$srcdir"/tftpy-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="b306d30ef1799f1932540a54cd72f79d tftpy-0.6.0.tar.gz"