summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorDuane Hughes <duanejevon@gmail.com>2011-01-28 09:30:23 +0000
committerJeff Bilyk <jbilyk@gmail.com>2011-02-07 20:17:36 +0000
commit5bed5e236349ddb404d3c6d586ea8f00cf7948ed (patch)
treec86c21038930b2ceb17188dacb38b6107dca1abd /testing
parentce1a7391837f485d1964e7540be744357fd616bd (diff)
downloadaports-5bed5e236349ddb404d3c6d586ea8f00cf7948ed.tar.bz2
aports-5bed5e236349ddb404d3c6d586ea8f00cf7948ed.tar.xz
testing/liblockfile: new aport
library files for file locking tools
Diffstat (limited to 'testing')
-rw-r--r--testing/liblockfile/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/liblockfile/APKBUILD b/testing/liblockfile/APKBUILD
new file mode 100644
index 000000000..6f471cb11
--- /dev/null
+++ b/testing/liblockfile/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Duane Hughes <duanejevon@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=liblockfile
+pkgver=1.08
+pkgrel=0
+pkgdesc="Shared library with NFS-safe locking functions"
+url="http://packages.debian.org/sid/liblockfile1"
+arch="all"
+license="GPL"
+depends=""
+makedepends=
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://ftp.debian.org/debian/pool/main/libl/liblockfile/${pkgname}_$pkgver.orig.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man
+ make -j1 || return 1
+}
+
+package() {
+ cd "$_builddir"
+
+ install -d "$pkgdir"/usr/include
+ install -d "$pkgdir"/usr/bin
+ install -d "$pkgdir"/usr/lib
+ install -d "$pkgdir"/usr/share/man
+
+ make -j1 ROOT="$pkgdir" install
+}
+
+md5sums="c24e2dfb4a2aab0263fe5ac1564d305e liblockfile_1.08.orig.tar.gz"