summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2015-06-14 12:12:38 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2015-06-14 12:12:48 +0200
commit666a8389a5bc6f2c0b847ae2a21312ae389edbfd (patch)
treef597df9ddfa897c0d22657fb45a8ca8abdbbf4c2 /testing
parent46e7c4d4ff65c87f724ee42b3595ba0f5ed2cb17 (diff)
downloadaports-666a8389a5bc6f2c0b847ae2a21312ae389edbfd.tar.bz2
aports-666a8389a5bc6f2c0b847ae2a21312ae389edbfd.tar.xz
testing/ttf-heuristica: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/ttf-heuristica/45-heuristica.conf12
-rw-r--r--testing/ttf-heuristica/90-tt-heuristica.conf26
-rw-r--r--testing/ttf-heuristica/APKBUILD50
3 files changed, 88 insertions, 0 deletions
diff --git a/testing/ttf-heuristica/45-heuristica.conf b/testing/ttf-heuristica/45-heuristica.conf
new file mode 100644
index 000000000..a0f7b1160
--- /dev/null
+++ b/testing/ttf-heuristica/45-heuristica.conf
@@ -0,0 +1,12 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+
+ <alias>
+ <family>Heuristica</family>
+ <default>
+ <family>serif</family>
+ </default>
+ </alias>
+
+</fontconfig>
diff --git a/testing/ttf-heuristica/90-tt-heuristica.conf b/testing/ttf-heuristica/90-tt-heuristica.conf
new file mode 100644
index 000000000..a86df21a3
--- /dev/null
+++ b/testing/ttf-heuristica/90-tt-heuristica.conf
@@ -0,0 +1,26 @@
+<?xml version='1.0'?>
+<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
+<fontconfig>
+
+ <match target="font">
+ <test name="force_autohint">
+ <bool>false</bool>
+ </test>
+ <test name="family">
+ <string>Heuristica</string>
+ </test>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="autohint" mode="assign">
+ <bool>false</bool>
+ </edit>
+ </match>
+
+</fontconfig>
diff --git a/testing/ttf-heuristica/APKBUILD b/testing/ttf-heuristica/APKBUILD
new file mode 100644
index 000000000..154849b09
--- /dev/null
+++ b/testing/ttf-heuristica/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=ttf-heuristica
+pkgver=1.0.2
+pkgrel=0
+pkgdesc="Heuristica is an extended version of Adobe Utopia ttf font."
+url="http://code.google.com/p/evristika/"
+arch="noarch"
+license="OFL"
+depends="fontconfig"
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+# added fontconfig configuration from:
+# https://github.com/bohoomil/fontconfig-ultimate/tree/master/fontconfig_patches/fonts-settings
+source="https://downloads.sourceforge.net/project/heuristica/heuristica-ttf-${pkgver}.tar.xz
+ 45-heuristica.conf
+ 90-tt-heuristica.conf"
+
+_builddir="$srcdir"
+
+build() {
+ cd "$_builddir"
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/share/fonts/$pkgname \
+ "$pkgdir"/etc/fonts/conf.avail \
+ "$pkgdir"/etc/fonts/conf.d
+ for i in "$_builddir"/*.ttf; do
+ install -m644 "$i" \
+ "$pkgdir"/usr/share/fonts/$pkgname/ || return 1
+ done
+ for j in "$srcdir"/*.conf; do
+ install -m644 "$j" \
+ "$pkgdir"/etc/fonts/conf.avail/ || return 1
+ cd "$pkgdir"/etc/fonts/conf.d
+ ln -sf /etc/fonts/conf.avail/${j##*/}
+ done
+}
+md5sums="874fe2d962cc511aa9d4edbded8205af heuristica-ttf-1.0.2.tar.xz
+aebd478b94816248f486e17a5627cc8e 45-heuristica.conf
+42907dcc7ce2ef65c24a14c195963e71 90-tt-heuristica.conf"
+sha256sums="08bf21e44941d195dceab637c3d8e22f4b5ce8490c83993cebd85d721b92553d heuristica-ttf-1.0.2.tar.xz
+eac2ffc894005dc53357d649ce2cf73102e50740ecccc977f5aeed2e4ffaefe0 45-heuristica.conf
+e433412ca046a2d29fa02b99b8c282a4220ad5e638efb7647cebda75e409824b 90-tt-heuristica.conf"
+sha512sums="8b763a8f44444a96a454d2b1e987e095fc72a67c3c0be4d24a18b6ddd417cb2bbdb57475b5c9515c3e0efb96d4afd5cf6095685ab035f8af4fff7f7e6f9ffb3d heuristica-ttf-1.0.2.tar.xz
+684250c4c575c41d5ea1eff7566532fe5ea2c31c62f35e7e9933dd9212addef980521a3b9421619fdeeec65d0e6863ce7f75ca5b8b00bd749abc654877f569d2 45-heuristica.conf
+9a3f68237a7f5c61e745bcf74f4319133fbaebbbf69a4ad2770d572820fc4b1d08b13e6482001f236f0976bb893d726f7fea2fe904ad60d7e5327561e2c91e24 90-tt-heuristica.conf"