summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorPeter Bui <pnutzh4x0r@gmail.com>2015-06-03 01:04:05 -0500
committerFrancesco Colista <fcolista@alpinelinux.org>2015-06-09 12:44:02 +0000
commit8d0103adac2832a482fc54c3ae2803d6b4646201 (patch)
tree690a205e4138fa6e7dde0dc924970e6dbb0407de /testing
parentc0b975f495a6638f86aaf7941ff25fb73d5bd1b0 (diff)
downloadaports-8d0103adac2832a482fc54c3ae2803d6b4646201.tar.bz2
aports-8d0103adac2832a482fc54c3ae2803d6b4646201.tar.xz
testing/py-gflags: new aport
http://code.google.com/p/python-gflags Commandline flags module for Python
Diffstat (limited to 'testing')
-rw-r--r--testing/py-gflags/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/py-gflags/APKBUILD b/testing/py-gflags/APKBUILD
new file mode 100644
index 000000000..aa5b3e323
--- /dev/null
+++ b/testing/py-gflags/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
+# Maintainer: Peter Bui <pnutzh4x0r@gmail.com>
+pkgname=py-gflags
+pkgver=2.0
+pkgrel=0
+pkgdesc="Commandline flags module for Python"
+url="http://code.google.com/p/python-gflags"
+arch="noarch"
+license="BSD"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://python-gflags.googlecode.com/files/python-gflags-${pkgver}.tar.gz"
+
+_builddir="$srcdir"/python-gflags-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="c3ab70218dbf945cc32c0cd64c51d162 python-gflags-2.0.tar.gz"
+sha256sums="311066217acb8cd8519a4c872cb3fe64f02bcf105802bb761ab0de55c2386cd6 python-gflags-2.0.tar.gz"
+sha512sums="28566acffd092f09105f3b9ad3be4ada11f024f940914e6efb103907f3779283c63bdfe13edad83aa470c5e887b49ad8b05031fc1895f3bad9b5d9c368bbfe18 python-gflags-2.0.tar.gz"