summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorAndrew Hills <ahills@ednos.net>2015-06-07 19:39:28 -0400
committerFrancesco Colista <fcolista@alpinelinux.org>2015-06-09 14:22:28 +0000
commita3cc350c9f3bcd37a902d47fc9b950ba23532cec (patch)
tree0a2aaebceb68aca452c58a4ce974c139dba21f0d /testing
parent52c05b05e2cef41868c948af85d5aa8cecba6b55 (diff)
downloadaports-a3cc350c9f3bcd37a902d47fc9b950ba23532cec.tar.bz2
aports-a3cc350c9f3bcd37a902d47fc9b950ba23532cec.tar.xz
testing/zathura-ps: new aport
https://pwmt.org/projects/zathura-ps Postscript support for zathura
Diffstat (limited to 'testing')
-rw-r--r--testing/zathura-ps/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/zathura-ps/APKBUILD b/testing/zathura-ps/APKBUILD
new file mode 100644
index 000000000..4b7b59eba
--- /dev/null
+++ b/testing/zathura-ps/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Andrew Hills <ahills@ednos.net>
+# Maintainer: Andrew Hills <ahills@ednos.net>
+pkgname=zathura-ps
+pkgver=0.2.2
+pkgrel=0
+pkgdesc="Postscript support for zathura"
+url="https://pwmt.org/projects/zathura-ps"
+arch="all"
+license="zlib"
+depends=""
+depends_dev=""
+makedepends="$depends_dev zathura-dev girara-dev libspectre-dev gtk+3.0-dev glib-dev"
+install=""
+subpackages=""
+source="https://pwmt.org/projects/zathura-ps/download/zathura-ps-$pkgver.tar.gz"
+
+_builddir="$srcdir"/zathura-ps-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="338af976c03c0aa1471b156a0efdc45c zathura-ps-0.2.2.tar.gz"
+sha256sums="e6546261db03b0b6b6499a8e109dc9ff3b8eb8b154ce45f5c6284c1e76d1d7a8 zathura-ps-0.2.2.tar.gz"
+sha512sums="4cedd614127b995ad834d5913dd5d9b3dff6172ac31cf42e8d43941815ac03a4872f41d7766c325f435feffa63364c9c377f760cd0540d2f36753e7df1c4c49e zathura-ps-0.2.2.tar.gz"