summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorPeter Bui <pnutzh4x0r@gmail.com>2015-06-03 01:04:04 -0500
committerFrancesco Colista <fcolista@alpinelinux.org>2015-06-09 12:26:12 +0000
commita864bc6a7797842958dfae7c368f4d109abf13c6 (patch)
tree6ea679981d5746b61130a35516c99c5de44872a1 /testing
parent00752a0a20e777a2d4e8dda76cff923fb798b9ec (diff)
downloadaports-a864bc6a7797842958dfae7c368f4d109abf13c6.tar.bz2
aports-a864bc6a7797842958dfae7c368f4d109abf13c6.tar.xz
testing/py-icu: new aport
http://pyicu.osafoundation.org/ Python binding for ICU
Diffstat (limited to 'testing')
-rw-r--r--testing/py-icu/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-icu/APKBUILD b/testing/py-icu/APKBUILD
new file mode 100644
index 000000000..c7b1beea6
--- /dev/null
+++ b/testing/py-icu/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
+# Maintainer:
+pkgname=py-icu
+_pkgname=PyICU
+pkgver=1.9.2
+pkgrel=0
+pkgdesc="Python binding for ICU"
+url="http://pyicu.osafoundation.org/"
+arch="all"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev icu-dev"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="a104ea78918a8b1f4ecbbb1063edb46b PyICU-1.9.2.tar.gz"
+sha256sums="9b580801eb17b09a5e0e8ef7d3b29170361ed505c5f954b723c1b48a1e502bb6 PyICU-1.9.2.tar.gz"
+sha512sums="1964464f5385dc8f65c4b88b63cd9f34ced1ae365562386708d92fc5c40090a40554578bd5e90d0a996ca6f012b3d2a8ab6e0fd07968e94a0dfe18894e8f08f4 PyICU-1.9.2.tar.gz"