summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-06-12 06:43:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-06-12 06:43:56 +0000
commitcfaa8ba0c702343efc1918ad0faac7795b55c104 (patch)
tree9b1d2ca98be57c6008d511d1bad14db7808095bb /testing
parent882c8c208b311fc38dc1ae5c7885c973d21537a0 (diff)
downloadaports-cfaa8ba0c702343efc1918ad0faac7795b55c104.tar.bz2
aports-cfaa8ba0c702343efc1918ad0faac7795b55c104.tar.xz
testing/libressl: upgrade to 2.2.0
Diffstat (limited to 'testing')
-rw-r--r--testing/libressl/APKBUILD15
-rw-r--r--testing/libressl/musl-fixes.patch10
2 files changed, 20 insertions, 5 deletions
diff --git a/testing/libressl/APKBUILD b/testing/libressl/APKBUILD
index 53742e9e0..84227864d 100644
--- a/testing/libressl/APKBUILD
+++ b/testing/libressl/APKBUILD
@@ -3,7 +3,7 @@
#
#
pkgname=libressl
-pkgver=2.1.4
+pkgver=2.2.0
pkgrel=0
pkgdesc="FREE version of the SSL/TLS protocol forked from OpenSSL - Portable edition"
url="http://www.libressl.org/"
@@ -14,7 +14,9 @@ depends_dev=""
makedepends="$depends_dev linux-headers"
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${pkgname}-${pkgver}.tar.gz"
+source="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${pkgname}-${pkgver}.tar.gz
+ musl-fixes.patch
+ "
_builddir="${srcdir}/${pkgname}-${pkgver}"
prepare() {
@@ -47,6 +49,9 @@ package() {
rm -f "$pkgdir"/usr/lib/*.la
}
-md5sums="147105631f34f18047c19483410db384 libressl-2.1.4.tar.gz"
-sha256sums="e8e08535928774119a979412ee8e307444b7a1a42c8c47ac06ee09423ca9a04e libressl-2.1.4.tar.gz"
-sha512sums="534ac8cd438d2907025dcb7e24394e004058db33585d5aff3b594ea7494a866d05d5076f24836dcaf38e6fb27227019d55c26ed235f61da20a158c200f18c46e libressl-2.1.4.tar.gz"
+md5sums="277e4bd258fd4fb2aadaed760320c566 libressl-2.2.0.tar.gz
+7d3e35bfd4241c680f63007761a6fd77 musl-fixes.patch"
+sha256sums="9690d8f38a5d48425395452eeb305b05bb0f560cd96e0ee30f370d4f16563040 libressl-2.2.0.tar.gz
+1e331cddc51e5dc5d0233032b5fe51c5a3a364d2dbd4b746d928358590d86277 musl-fixes.patch"
+sha512sums="aee06cf98dfeda9ff68c0db5c36c4f00ae0d436fadccaf811ff6c5ba26ef9e0ff73afb9034b1e3bf2715938a420ed297beee5102442b3bf5d344647d33c04e02 libressl-2.2.0.tar.gz
+ac83a7c3e3f937500d6c296bb40c4d48938278ddb7f4a751df398bfcc981e613bce10eaae93f0c8bfceb99dd9c1ae1e06c2ff03dff75662300f80f792d0c5826 musl-fixes.patch"
diff --git a/testing/libressl/musl-fixes.patch b/testing/libressl/musl-fixes.patch
new file mode 100644
index 000000000..836e9167c
--- /dev/null
+++ b/testing/libressl/musl-fixes.patch
@@ -0,0 +1,10 @@
+--- ./crypto/compat/getentropy_linux.c.orig
++++ ./crypto/compat/getentropy_linux.c
+@@ -28,7 +28,6 @@
+ #include <sys/resource.h>
+ #include <sys/syscall.h>
+ #ifdef SYS__sysctl
+-#include <sys/sysctl.h>
+ #include <linux/sysctl.h>
+ #endif
+ #include <sys/statvfs.h>