summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2015-05-01 16:58:38 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2015-05-05 01:01:00 +0200
commitede1fe4919ddee8eba97a32847bbd2f169d4d302 (patch)
tree1f493e2aea0d62dbc0e7fc3cad0934fa4af456a3 /testing
parent7d10f820094f2221b55f6e49274d508b2c16b7b4 (diff)
downloadaports-ede1fe4919ddee8eba97a32847bbd2f169d4d302.tar.bz2
aports-ede1fe4919ddee8eba97a32847bbd2f169d4d302.tar.xz
testing/entr: new aport
Event Notify Test Runner: Run arbitrary commands when files change http://entrproject.org 41k binary
Diffstat (limited to 'testing')
-rw-r--r--testing/entr/APKBUILD43
-rw-r--r--testing/entr/remove-strlcpy-compat.h.patch14
2 files changed, 57 insertions, 0 deletions
diff --git a/testing/entr/APKBUILD b/testing/entr/APKBUILD
new file mode 100644
index 000000000..4a1f5689b
--- /dev/null
+++ b/testing/entr/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=entr
+_srcdir=eradman-$pkgname-c20e34ec153a
+pkgver=3.2
+pkgrel=0
+pkgdesc="Event Notify Test Runner: Run arbitrary commands when files change"
+url="http://entrproject.org"
+arch="all"
+license="ISC / BSD"
+subpackages="$pkgname-doc"
+source="http://entrproject.org/code/$pkgname-$pkgver.tar.gz
+ remove-strlcpy-compat.h.patch
+ "
+
+_builddir="$srcdir"/$_srcdir
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure || return 1
+ CFLAGS="-static" make test || return 1
+}
+
+package() {
+ cd "$_builddir"
+ PREFIX="$pkgdir/usr" make install || return 1
+}
+
+md5sums="efd379cf5bd08d7086bb94e41c4846c8 entr-3.2.tar.gz
+5ae5aa6f2b8de9747312b32b17c56d0b remove-strlcpy-compat.h.patch"
+sha256sums="b1eee00afbeccf03010c1c557436854be6aaf0ef9b72ab8d44b94affdd7d7146 entr-3.2.tar.gz
+2bc42c8c154acf0aaa876b4395c2e0e7b20773e48d50b0c8a15e90ca2e8db472 remove-strlcpy-compat.h.patch"
+sha512sums="7287dfe86b829a73049dfbac78c76e06e69b1172bece80120977f03492ff325d0c026cb58d1ab56a10897beebbcfb0c2130aaf5167ad68fdbc5daa0959cc22b7 entr-3.2.tar.gz
+9d0f4e06cd5c312788f5ff2efa13f55f78a3491de3ddf64612a6c731072e8514deb1cea48c630194cbda71c58c57e9a6b937172eca58be0b1fb4f0f7a1652e2d remove-strlcpy-compat.h.patch"
diff --git a/testing/entr/remove-strlcpy-compat.h.patch b/testing/entr/remove-strlcpy-compat.h.patch
new file mode 100644
index 000000000..ae2d271a1
--- /dev/null
+++ b/testing/entr/remove-strlcpy-compat.h.patch
@@ -0,0 +1,14 @@
+--- eradman-entr-c20e34ec153a/missing/compat.h
++++ eradman-entr-c20e34ec153a/missing/compat.h.new
+@@ -4,11 +4,6 @@
+ #define NOTE_TRUNCATE 0
+ #endif
+
+-#if defined(_LINUX_PORT)
+-#include <sys/types.h>
+-size_t strlcpy(char *to, const char *from, int l);
+-#endif
+-
+ #if defined(_MACOS_PORT)
+ #include <stdio.h>
+ FILE *fmemopen(void *buf, size_t size, const char *mode);