summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorPeter Bui <pnutzh4x0r@gmail.com>2015-06-03 01:04:08 -0500
committerFrancesco Colista <fcolista@alpinelinux.org>2015-06-09 12:44:02 +0000
commitf6481045e9ceedda81d5ea96038c9e84ba569ab1 (patch)
treeb601b2745df2d8c0f349cc9a763aea1f9ba856f8 /testing
parenta75dac75da42910002c9fdbd28fcc610186fa2de (diff)
downloadaports-f6481045e9ceedda81d5ea96038c9e84ba569ab1.tar.bz2
aports-f6481045e9ceedda81d5ea96038c9e84ba569ab1.tar.xz
testing/py-oauth2client: new aport
https://github.com/google/oauth2client A client library for OAuth 2.0
Diffstat (limited to 'testing')
-rw-r--r--testing/py-oauth2client/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-oauth2client/APKBUILD b/testing/py-oauth2client/APKBUILD
new file mode 100644
index 000000000..63c017389
--- /dev/null
+++ b/testing/py-oauth2client/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
+# Maintainer:
+pkgname=py-oauth2client
+_pkgname=oauth2client
+pkgver=1.4.11
+pkgrel=0
+pkgdesc="A client library for OAuth 2.0"
+url="https://github.com/google/oauth2client"
+arch="noarch"
+license="Apache"
+depends="python py-asn1 py-httplib2 py-asn1-modules py-rsa py-six"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="ace6b6e4c9cd17fd611d9984d6746c7b oauth2client-1.4.11.tar.gz"
+sha256sums="dcc9bfaa544791206ca86a2f311872f0c4c1e81b068775c3da16abe72a506873 oauth2client-1.4.11.tar.gz"
+sha512sums="46e5b475fd032bc1de6cb4a404747a62988fc337c9c73a329cf4127fc4a1966124a506316fb4a4e90ea68e78103cab571cd42f9eb683ce1413c8a501ace5ed91 oauth2client-1.4.11.tar.gz"