summaryrefslogtreecommitdiffstats
path: root/unmaintained/py-apache-libcloud
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2014-05-30 20:33:49 +0200
committerBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2014-05-30 20:33:49 +0200
commit90c2280235c344f27753e2d6bf551577a30e7710 (patch)
tree40e625ec3676772113c76e2bfe7e134be7a1136f /unmaintained/py-apache-libcloud
parentdad96643d836e7fcc50caf2f5ee399f7b0b1782c (diff)
downloadaports-90c2280235c344f27753e2d6bf551577a30e7710.tar.bz2
aports-90c2280235c344f27753e2d6bf551577a30e7710.tar.xz
testing/py-apache-libcloud: move to unmaintained
Diffstat (limited to 'unmaintained/py-apache-libcloud')
-rw-r--r--unmaintained/py-apache-libcloud/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/unmaintained/py-apache-libcloud/APKBUILD b/unmaintained/py-apache-libcloud/APKBUILD
new file mode 100644
index 000000000..954a196c1
--- /dev/null
+++ b/unmaintained/py-apache-libcloud/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer:
+pkgname=py-apache-libcloud
+_pkgname=apache-libcloud
+pkgver=0.13.0
+pkgrel=0
+pkgdesc="A Python library that abstracts away differences among multiple cloud provider APIs"
+url="https://libcloud.apache.org"
+arch="noarch"
+license="ASL 2.0"
+depends=""
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://www.apache.org/dist/libcloud/$_pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="b493c24fecc4e9ad86322d021cb3fbfd apache-libcloud-0.13.0.tar.bz2"
+sha256sums="e26ee90d81ed996112bfe744a0d3f33a07bcf98dd41ec01f129e1682de1ddac5 apache-libcloud-0.13.0.tar.bz2"
+sha512sums="b82176cfb54cb6a83e2096e92ef2bbc2e094df36fdd7d107b43ce46382629537b1fdab4fca6f8f451df8566052553bfaa1301e0256a19f12dae2c709f84429a4 apache-libcloud-0.13.0.tar.bz2"