summaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-10-26 13:07:13 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2014-10-26 13:07:13 +0100
commit3b96db9e41611b61d7df6ffd57c5c72135f2df0b (patch)
treeb9c739eaeeb9249afb13b92035806dd0fe18feb2 /unmaintained
parentac1db43edf9622514a9945cd1ff1cbb4b2080cc3 (diff)
downloadaports-3b96db9e41611b61d7df6ffd57c5c72135f2df0b.tar.bz2
aports-3b96db9e41611b61d7df6ffd57c5c72135f2df0b.tar.xz
testing/obexftp: move to unmaintained
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/obexftp/APKBUILD57
-rw-r--r--unmaintained/obexftp/obexftp-0.23-gentoo.patch24
2 files changed, 81 insertions, 0 deletions
diff --git a/unmaintained/obexftp/APKBUILD b/unmaintained/obexftp/APKBUILD
new file mode 100644
index 000000000..bcde5b0c9
--- /dev/null
+++ b/unmaintained/obexftp/APKBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=obexftp
+pkgver=0.23
+pkgrel=4
+pkgdesc="A tool for transfer files to/from any OBEX enabled device"
+url="http://openobex.triq.net/obexftp/obexftp"
+arch="all"
+license="GPL"
+depends=
+makedepends="pkgconfig openobex-dev bluez-dev python-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs py-$pkgname:py"
+source="http://downloads.sourceforge.net/sourceforge/openobex/obexftp-$pkgver.tar.bz2
+ obexftp-0.23-gentoo.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case "$i" in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --enable-bluetooth \
+ --disable-perl \
+ --enable-python \
+ --disable-ruby || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm "$pkgdir"/usr/lib/*.la
+}
+
+libs() {
+ pkgdesc="OBEX shared library"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/lib*.so.* "$subpkgdir"/usr/lib
+}
+
+py() {
+ pkgdesc="Python library to access devices via the OBEX protocol"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+
+md5sums="f20762061b68bc921e80be4aebc349eb obexftp-0.23.tar.bz2
+90b4fadb913673c339bbd04cebc4f9d2 obexftp-0.23-gentoo.patch"
diff --git a/unmaintained/obexftp/obexftp-0.23-gentoo.patch b/unmaintained/obexftp/obexftp-0.23-gentoo.patch
new file mode 100644
index 000000000..b805bc625
--- /dev/null
+++ b/unmaintained/obexftp/obexftp-0.23-gentoo.patch
@@ -0,0 +1,24 @@
+diff -Nru obexftp-0.23.orig/obexftp/client.c obexftp-0.23/obexftp/client.c
+--- obexftp-0.23.orig/obexftp/client.c 2009-02-17 18:27:48.000000000 +0000
++++ obexftp-0.23/obexftp/client.c 2009-03-22 16:12:05.000000000 +0000
+@@ -51,8 +51,6 @@
+
+ #ifdef HAVE_BLUETOOTH
+ #include "bt_kit.h"
+-#else
+-#define ESOCKTNOSUPPORT WSAESOCKTNOSUPPORT
+ #endif /* HAVE_BLUETOOTH */
+
+ #include <openobex/obex.h>
+diff -Nru obexftp-0.23.orig/apps/obexftp.c obexftp-0.23/apps/obexftp.c
+--- obexftp-0.23.orig/apps/obexftp.c 2009-02-17 18:27:48.000000000 +0000
++++ obexftp-0.23/apps/obexftp.c 2009-03-22 16:19:29.000000000 +0000
+@@ -29,6 +29,8 @@
+
+ #include <sys/types.h>
+
++#include <config.h>
++
+ #ifdef HAVE_SYS_TIMES_H
+ #include <sys/times.h>
+ #endif