summaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-10-29 10:50:06 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2014-10-29 10:50:38 +0100
commit0a407859791268c4ad134f1c1521e148714e81c4 (patch)
tree23d0206497f90c79b34ffd5cafa5e7f518e39d51 /unmaintained
parent95b7314e09e755da1569ceb20a398d24276dc7bc (diff)
downloadaports-0a407859791268c4ad134f1c1521e148714e81c4.tar.bz2
aports-0a407859791268c4ad134f1c1521e148714e81c4.tar.xz
unmaintained/deadbeef: upgrade to 0.6.2
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/deadbeef/6d39333448dd7c48fb3f4e07ff5d7e05d0527fff.patch40
-rw-r--r--unmaintained/deadbeef/APKBUILD26
-rw-r--r--unmaintained/deadbeef/deadbeef-junklib.patch10
-rw-r--r--unmaintained/deadbeef/ee8e3065ab22e812fecc85d5dcf6b45d605b01fc.patch47
-rw-r--r--unmaintained/deadbeef/ffmpeg-avmedia_type.patch31
5 files changed, 104 insertions, 50 deletions
diff --git a/unmaintained/deadbeef/6d39333448dd7c48fb3f4e07ff5d7e05d0527fff.patch b/unmaintained/deadbeef/6d39333448dd7c48fb3f4e07ff5d7e05d0527fff.patch
new file mode 100644
index 000000000..3de7b1d61
--- /dev/null
+++ b/unmaintained/deadbeef/6d39333448dd7c48fb3f4e07ff5d7e05d0527fff.patch
@@ -0,0 +1,40 @@
+From 6d39333448dd7c48fb3f4e07ff5d7e05d0527fff Mon Sep 17 00:00:00 2001
+From: Carlo Landmeter <clandmeter@gmail.com>
+Date: Wed, 29 Oct 2014 10:36:57 +0100
+Subject: [PATCH] musl libc does not have execinfo.h
+
+---
+ main.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/main.c b/main.c
+index d7dab49..797889c 100644
+--- a/main.c
++++ b/main.c
+@@ -51,7 +51,7 @@
+ #include <sys/fcntl.h>
+ #include <sys/errno.h>
+ #include <signal.h>
+-#ifdef __linux__
++#ifdef __GLIBC__
+ #include <execinfo.h>
+ #endif
+ #include <unistd.h>
+@@ -642,7 +642,7 @@ player_mainloop (void) {
+ }
+ }
+
+-#ifdef __linux__
++#ifdef __GLIBC__
+ void
+ sigsegv_handler (int sig) {
+ fprintf (stderr, "Segmentation Fault\n");
+@@ -761,7 +761,7 @@ main (int argc, char *argv[]) {
+ }
+ #endif
+
+-#ifdef __linux__
++#ifdef __GLIBC__
+ signal (SIGSEGV, sigsegv_handler);
+ #endif
+ setlocale (LC_ALL, "");
diff --git a/unmaintained/deadbeef/APKBUILD b/unmaintained/deadbeef/APKBUILD
index 623a01cb0..50b0e7477 100644
--- a/unmaintained/deadbeef/APKBUILD
+++ b/unmaintained/deadbeef/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=deadbeef
-pkgver=0.5.1
+pkgver=0.6.2
_ver=${pkgver/_rc/-rc}
pkgrel=0
pkgdesc="fairly capable playlist-oriented audio player"
@@ -15,10 +15,11 @@ makedepends="$depends_dev intltool"
install=""
subpackages="$pkgname-dev $pkgname-lang"
source="http://downloads.sourceforge.net/project/$pkgname/$pkgname-$_ver.tar.bz2
- deadbeef-junklib.patch
- ffmpeg-avmedia_type.patch"
+ 6d39333448dd7c48fb3f4e07ff5d7e05d0527fff.patch
+ ee8e3065ab22e812fecc85d5dcf6b45d605b01fc.patch"
_builddir="${srcdir}/${pkgname}-$_ver"
+
prepare() {
local i
cd "$_builddir"
@@ -31,10 +32,11 @@ prepare() {
build() {
cd "$_builddir"
- LIBS="-lintl" ./configure --prefix=/usr \
+ #LIBS="-lintl"
+ ./configure --prefix=/usr \
--sysconfdir=/etc \
- --disable-sid \
- --disable-ffap || return 1
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info || return 1
make || return 1
}
@@ -44,6 +46,12 @@ package() {
rm "$pkgdir"/usr/lib/deadbeef/*.la
}
-md5sums="be8359d1bd9cf7679cf2ca748996e726 deadbeef-0.5.1.tar.bz2
-8bf4eb1c52f251da7c7a78b2bb021359 deadbeef-junklib.patch
-fec3680b1e06702265313d6ef13c025e ffmpeg-avmedia_type.patch"
+md5sums="786f3a01fc9e03e73191d1cce43250a3 deadbeef-0.6.2.tar.bz2
+deca108872fd1149d89567f438afcf0a 6d39333448dd7c48fb3f4e07ff5d7e05d0527fff.patch
+e27f4cea7ce03505fa4256427972d98e ee8e3065ab22e812fecc85d5dcf6b45d605b01fc.patch"
+sha256sums="3433b966683286c03ffbcc79b2201cd517f8dbf6b41da8600778dfa93cd64e1a deadbeef-0.6.2.tar.bz2
+516f1dee6a01fa87f0f58c97cdfaf05dce45837f8256815fd5853ced8a688e84 6d39333448dd7c48fb3f4e07ff5d7e05d0527fff.patch
+639d94304a165dbc5afaa56587b29d2d2f8a35410b4d002d2308e8f95e8e2f5c ee8e3065ab22e812fecc85d5dcf6b45d605b01fc.patch"
+sha512sums="7caee245d7fa68e98ce5edc6aa6acc829d62c963f523c81e0406182a1aa36759219a8c0a2bdf010ac810f22b15acc81d06e8cab4ab820956c96cbc0a94423b7b deadbeef-0.6.2.tar.bz2
+f15658cdffd4b9979e6beb9cf12f5d367e082a36098fd642f1fb98536e8c583259a9ed06e41d4a532d469dbe2548dbab40ca4c1c6614dac333311ecef17678a4 6d39333448dd7c48fb3f4e07ff5d7e05d0527fff.patch
+cb9952c4ef7ba8f60db6358232684ebb3200035bffcf1a0ceba1e8798eb12bc83f5ca10a9d680973696d59793bb6fa37cab0a40ceff7d0e5cfeab78747a9b56c ee8e3065ab22e812fecc85d5dcf6b45d605b01fc.patch"
diff --git a/unmaintained/deadbeef/deadbeef-junklib.patch b/unmaintained/deadbeef/deadbeef-junklib.patch
deleted file mode 100644
index 63a29ca93..000000000
--- a/unmaintained/deadbeef/deadbeef-junklib.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- deadbeef-0.5.0-rc1.orig/junklib.c
-+++ deadbeef-0.5.0-rc1/junklib.c
-@@ -23,7 +23,6 @@
- #include <stdlib.h>
- #include <string.h>
- #if HAVE_ICONV
-- #define LIBICONV_PLUG
- #include <iconv.h>
- #elif HAVE_ICU
- #warning icu
diff --git a/unmaintained/deadbeef/ee8e3065ab22e812fecc85d5dcf6b45d605b01fc.patch b/unmaintained/deadbeef/ee8e3065ab22e812fecc85d5dcf6b45d605b01fc.patch
new file mode 100644
index 000000000..b3e34bdbf
--- /dev/null
+++ b/unmaintained/deadbeef/ee8e3065ab22e812fecc85d5dcf6b45d605b01fc.patch
@@ -0,0 +1,47 @@
+From ee8e3065ab22e812fecc85d5dcf6b45d605b01fc Mon Sep 17 00:00:00 2001
+From: Carlo Landmeter <clandmeter@gmail.com>
+Date: Wed, 29 Oct 2014 10:36:12 +0100
+Subject: [PATCH] musl libc needs limits.h inclusion
+
+---
+ conf.c | 1 +
+ plugins/converter/converter.c | 1 +
+ plugins/m3u/m3u.c | 1 +
+ 3 files changed, 3 insertions(+)
+
+diff --git a/conf.c b/conf.c
+index 110bf4e..8bb160e 100644
+--- a/conf.c
++++ b/conf.c
+@@ -29,6 +29,7 @@
+ #include <stdint.h>
+ #include <string.h>
+ #include <stdlib.h>
++#include <limits.h>
+ #include <inttypes.h>
+ #include <errno.h>
+ #include <unistd.h>
+diff --git a/plugins/converter/converter.c b/plugins/converter/converter.c
+index f87f3f2..3151243 100644
+--- a/plugins/converter/converter.c
++++ b/plugins/converter/converter.c
+@@ -26,6 +26,7 @@
+ #include <sys/syslimits.h>
+ #endif
+ #include <stdlib.h>
++#include <limits.h>
+ #include <string.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+diff --git a/plugins/m3u/m3u.c b/plugins/m3u/m3u.c
+index ff3320b..62fda30 100644
+--- a/plugins/m3u/m3u.c
++++ b/plugins/m3u/m3u.c
+@@ -26,6 +26,7 @@
+ #endif
+ #include <string.h>
+ #include <stdlib.h>
++#include <limits.h>
+ #include <math.h> // for ceil
+ #if HAVE_SYS_SYSLIMITS_H
+ #include <sys/syslimits.h>
diff --git a/unmaintained/deadbeef/ffmpeg-avmedia_type.patch b/unmaintained/deadbeef/ffmpeg-avmedia_type.patch
deleted file mode 100644
index 111df4efc..000000000
--- a/unmaintained/deadbeef/ffmpeg-avmedia_type.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/plugins/ffmpeg/ffmpeg.c b/plugins/ffmpeg/ffmpeg.c
-index cd7edf4..36b6d4b 100644
---- a/plugins/ffmpeg/ffmpeg.c
-+++ b/plugins/ffmpeg/ffmpeg.c
-@@ -140,7 +140,7 @@ ffmpeg_init (DB_fileinfo_t *_info, DB_playItem_t *it) {
- for (i = 0; i < info->fctx->nb_streams; i++)
- {
- info->ctx = info->fctx->streams[i]->codec;
-- if (info->ctx->codec_type == CODEC_TYPE_AUDIO)
-+ if (info->ctx->codec_type == AVMEDIA_TYPE_AUDIO)
- {
- info->codec = avcodec_find_decoder (info->ctx->codec_id);
- if (info->codec != NULL) {
-@@ -490,7 +490,7 @@ ffmpeg_insert (ddb_playlist_t *plt, DB_playItem_t *after, const char *fname) {
- for (i = 0; i < fctx->nb_streams; i++)
- {
- ctx = fctx->streams[i]->codec;
-- if (ctx->codec_type == CODEC_TYPE_AUDIO)
-+ if (ctx->codec_type == AVMEDIA_TYPE_AUDIO)
- {
- codec = avcodec_find_decoder(ctx->codec_id);
- if (codec != NULL && !strcasecmp (codec->name, "alac")) { // only open alac streams
-@@ -745,7 +745,7 @@ ffmpeg_read_metadata (DB_playItem_t *it) {
- for (i = 0; i < fctx->nb_streams; i++)
- {
- ctx = fctx->streams[i]->codec;
-- if (ctx->codec_type == CODEC_TYPE_AUDIO)
-+ if (ctx->codec_type == AVMEDIA_TYPE_AUDIO)
- {
- codec = avcodec_find_decoder(ctx->codec_id);
- if (codec != NULL)