summaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-10-28 11:06:23 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2014-10-28 11:11:28 +0100
commit385bd35a39e326cf75930f4617effd16f9ac2226 (patch)
tree0801582a61726a56cf194f3c67abf1d9dca2b4d4 /unmaintained
parent70d08a7d5ac21427c2326b095d3169e5ddc8e35b (diff)
downloadaports-385bd35a39e326cf75930f4617effd16f9ac2226.tar.bz2
aports-385bd35a39e326cf75930f4617effd16f9ac2226.tar.xz
testing/fotox: unmaintained
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/fotoxx/APKBUILD39
-rw-r--r--unmaintained/fotoxx/no-xdg-desktop-menu.patch10
2 files changed, 49 insertions, 0 deletions
diff --git a/unmaintained/fotoxx/APKBUILD b/unmaintained/fotoxx/APKBUILD
new file mode 100644
index 000000000..e5ee47eae
--- /dev/null
+++ b/unmaintained/fotoxx/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=fotoxx
+pkgver=12.08
+pkgrel=0
+pkgdesc="Photo editing and collection management"
+url="http://kornelix.squarespace.com/fotoxx"
+arch="all"
+license="GPL-3"
+depends="xdg-utils exiftool"
+makedepends="gtk+3.0-dev tiff-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://www.kornelix.com/uploads/1/3/0/3/13035936/fotoxx-$pkgver.tar.gz
+ no-xdg-desktop-menu.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make PREFIX=/usr LDFLAGS="$LFDLAGS" CXXFLAGS="$CFLAGS" || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+md5sums="b4b2ae2395223487df8f435789fbc60a fotoxx-12.08.tar.gz
+8c988a8ced48cfe3a5a49be4a705b045 no-xdg-desktop-menu.patch"
diff --git a/unmaintained/fotoxx/no-xdg-desktop-menu.patch b/unmaintained/fotoxx/no-xdg-desktop-menu.patch
new file mode 100644
index 000000000..0e2813fb8
--- /dev/null
+++ b/unmaintained/fotoxx/no-xdg-desktop-menu.patch
@@ -0,0 +1,10 @@
+--- ./Makefile.orig
++++ ./Makefile
+@@ -76,7 +76,6 @@
+ rm -f fotoxx.1.gz
+ # menu (desktop) file
+ cp -f desktop $(DESTDIR)$(MENUFILE)
+- xdg-desktop-menu install $(DESTDIR)$(MENUFILE)
+
+ uninstall:
+ rm -f $(DESTDIR)$(BINDIR)/fotoxx