summaryrefslogtreecommitdiffstats
path: root/x11/dbus/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-03-31 06:57:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-03-31 06:57:29 +0000
commit30cd80745024945f8294733c0786780321f76e10 (patch)
tree8f9537f8c5053da4e8156c08d8fc0430ee0adc7a /x11/dbus/APKBUILD
parentb82c9254ba0176f35c8ba94c842d3006b6a171dc (diff)
downloadaports-30cd80745024945f8294733c0786780321f76e10.tar.bz2
aports-30cd80745024945f8294733c0786780321f76e10.tar.xz
x11/dbus: new aport
Freedesktop.org message bus system http://www.freedesktop.org/Software/dbus
Diffstat (limited to 'x11/dbus/APKBUILD')
-rw-r--r--x11/dbus/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11/dbus/APKBUILD b/x11/dbus/APKBUILD
new file mode 100644
index 000000000..399b1fe95
--- /dev/null
+++ b/x11/dbus/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=dbus
+pkgver=1.2.12
+pkgrel=0
+pkgdesc="Freedesktop.org message bus system"
+url="http://www.freedesktop.org/Software/dbus"
+license="GPL custom"
+subpackages="$pkgname-dev $pkgname-doc"
+depends="uclibc expat libx11"
+makedepends="expat-dev libx11-dev pkgconfig"
+install="$pkgname.pre-install"
+source="http://$pkgname.freedesktop.org/releases/$pkgname/$pkgname-$pkgver.tar.gz
+ $pkgname.initd
+ $install
+ "
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --with-xml=expat \
+ --with-dbus-user=messagebus \
+ --with-system-pid-file=/var/run/dbus.pid \
+ --disable-verbose-mode \
+ --disable-static \
+ --enable-inotify \
+ --disable-dnotify \
+ --disable-tests \
+ --disable-asserts \
+ --with-x || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+ install -Dm755 "$srcdir"/dbus.initd "$pkgdir"/etc/init.d/dbus
+}
+md5sums="39bd582c3b06a261cac44d4cab6fd60b dbus-1.2.12.tar.gz
+58356b4db650a89312a670c02804c540 dbus.initd
+1f3230e131a28409e8769c987b0f624a dbus.pre-install"