summaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-12-17 20:38:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-12-17 20:38:54 +0000
commit28a99d1025117434a6264513d4dbdcc919b787b1 (patch)
tree24277ae403ec9b66b35f947238f196c9c689bd32 /x11
parenta7a7d934d2bae31f509f657215c43f9dae9df96d (diff)
downloadaports-28a99d1025117434a6264513d4dbdcc919b787b1.tar.bz2
aports-28a99d1025117434a6264513d4dbdcc919b787b1.tar.xz
x11/xf86-input-mouse: rebuild with gcc-4.4.2
And use LDFLAGS for lazy binding
Diffstat (limited to 'x11')
-rw-r--r--x11/xf86-input-mouse/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/x11/xf86-input-mouse/APKBUILD b/x11/xf86-input-mouse/APKBUILD
index 5efda5695..b2aea2bb8 100644
--- a/x11/xf86-input-mouse/APKBUILD
+++ b/x11/xf86-input-mouse/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-input-mouse
pkgver=1.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="X.org mouse input driver"
url="http://xorg.freedesktop.org/"
license="custom"
@@ -10,13 +10,15 @@ depends=
makedepends="pkgconfig libxkbfile-dev xorg-server-dev libxi-dev libxrandr-dev"
source="http://xorg.freedesktop.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
-build ()
-{
+build() {
cd "$srcdir"/$pkgname-$pkgver
- export GCC_SPECS=/usr/share/gcc/hardenednoznow.specs
-
+ export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
./configure --prefix=/usr || return 1
make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install || return 1
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}