summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py-xattr/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py-xattr/APKBUILD b/testing/py-xattr/APKBUILD
new file mode 100644
index 000000000..9d0ec5d9d
--- /dev/null
+++ b/testing/py-xattr/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-xattr
+_pkgname=pyxattr
+pkgver=0.5.0
+pkgrel=0
+pkgdesc="A python module for accessing filesystem Extended Attributes"
+url="http://pyxattr.sourceforge.net/"
+arch="all"
+license="LGPL2+"
+depends=""
+depends_dev=""
+makedepends="python-dev attr-dev"
+install=""
+subpackages=""
+source="http://downloads.sourceforge.net/$_pkgname/$_pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root="$pkgdir" || return 1
+}
+
+md5sums="0f7ab1e185087329e40f7de218517c84 pyxattr-0.5.0.tar.gz"