summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11/ristretto/APKBUILD22
l---------x11/ristretto/ristretto.post-deinstall1
-rw-r--r--x11/ristretto/ristretto.post-install6
l---------x11/ristretto/ristretto.post-upgrade1
4 files changed, 11 insertions, 19 deletions
diff --git a/x11/ristretto/APKBUILD b/x11/ristretto/APKBUILD
index 5c651efb7..4daa72593 100644
--- a/x11/ristretto/APKBUILD
+++ b/x11/ristretto/APKBUILD
@@ -1,28 +1,28 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ristretto
pkgver=0.0.22
-pkgrel=0
+pkgrel=1
pkgdesc="Ristretto is a image viewer for Xfce"
url="http://goodies.xfce.org/projects/applications/ristretto"
license="GPL-2"
depends="desktop-file-utils hicolor-icon-theme"
makedepends="pkgconfig libxfcegui4-dev dbus-glib-dev libexif-dev intltool
gettext-dev libiconv-dev thunar-dev"
-install="ristretto.post-install ristretto.post-upgrade ristretto.post-deinstall"
-source="http://goodies.xfce.org/releases/$pkgname/$pkgname-$pkgver.tar.gz
- $install"
+install=
+source="http://goodies.xfce.org/releases/$pkgname/$pkgname-$pkgver.tar.gz"
-build ()
-{
+build() {
cd "$srcdir"/$pkgname-$pkgver
./configure --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
+ --enable-xfce-desktop \
--disable-static || return 1
- make || return 1
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="978ae19472c5a0b7d4b6622a68234a67 ristretto-0.0.22.tar.gz
-9ba052c0be9f3e3ae52ef7d45083efa3 ristretto.post-install
-9ba052c0be9f3e3ae52ef7d45083efa3 ristretto.post-upgrade
-9ba052c0be9f3e3ae52ef7d45083efa3 ristretto.post-deinstall"
+md5sums="978ae19472c5a0b7d4b6622a68234a67 ristretto-0.0.22.tar.gz"
diff --git a/x11/ristretto/ristretto.post-deinstall b/x11/ristretto/ristretto.post-deinstall
deleted file mode 120000
index 545052657..000000000
--- a/x11/ristretto/ristretto.post-deinstall
+++ /dev/null
@@ -1 +0,0 @@
-ristretto.post-install \ No newline at end of file
diff --git a/x11/ristretto/ristretto.post-install b/x11/ristretto/ristretto.post-install
deleted file mode 100644
index e3be6863e..000000000
--- a/x11/ristretto/ristretto.post-install
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-update-desktop-database -q
-gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-
-
diff --git a/x11/ristretto/ristretto.post-upgrade b/x11/ristretto/ristretto.post-upgrade
deleted file mode 120000
index 545052657..000000000
--- a/x11/ristretto/ristretto.post-upgrade
+++ /dev/null
@@ -1 +0,0 @@
-ristretto.post-install \ No newline at end of file