summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/talloc/APKBUILD8
-rw-r--r--main/talloc/always-libs.patch10
2 files changed, 15 insertions, 3 deletions
diff --git a/main/talloc/APKBUILD b/main/talloc/APKBUILD
index efc486367..1dacfa662 100644
--- a/main/talloc/APKBUILD
+++ b/main/talloc/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=talloc
pkgver=2.0.5
-pkgrel=1
+pkgrel=2
pkgdesc="memory pool management library"
url="http://talloc.samba.org/"
arch="all"
@@ -13,7 +13,8 @@ replaces="samba-common"
makedepends="$depends_dev python"
install=""
subpackages="$pkgname-dev"
-source="http://samba.org/ftp/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+source="http://samba.org/ftp/${pkgname}/${pkgname}-${pkgver}.tar.gz
+ always-libs.patch"
_builddir="${srcdir}/${pkgname}-${pkgver}"
prepare() {
@@ -39,4 +40,5 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="6e3fdfbc43dde8ccba27b6af894b8fb2 talloc-2.0.5.tar.gz"
+md5sums="6e3fdfbc43dde8ccba27b6af894b8fb2 talloc-2.0.5.tar.gz
+10304afbc3b00346238bf5a969227c68 always-libs.patch"
diff --git a/main/talloc/always-libs.patch b/main/talloc/always-libs.patch
new file mode 100644
index 000000000..e9658d4b9
--- /dev/null
+++ b/main/talloc/always-libs.patch
@@ -0,0 +1,10 @@
+--- ./buildtools/wafsamba/samba_conftests.py.orig
++++ ./buildtools/wafsamba/samba_conftests.py
+@@ -186,6 +186,7 @@
+ msg = "rpath library support"
+ else:
+ msg = "building library support"
++ return True
+
+ dir = find_config_dir(conf)
+