summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/git/APKBUILD6
-rw-r--r--main/git/git-daemon.confd3
-rw-r--r--main/git/git-daemon.initd5
3 files changed, 6 insertions, 8 deletions
diff --git a/main/git/APKBUILD b/main/git/APKBUILD
index 59608e28e..e1d61d3e4 100644
--- a/main/git/APKBUILD
+++ b/main/git/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=git
pkgver=1.7.3.5
-pkgrel=0
+pkgrel=1
pkgdesc="GIT - the stupid content tracker"
url="http://git.or.cz/"
arch="all"
@@ -53,5 +53,5 @@ perl() {
md5sums="8a8cd93b8a4dff0a03c0fdc77253af3e git-1.7.3.5.tar.bz2
e63a201556c4f089de790805c09a2e5b bb-tar.patch
-1afefbcc6f7535f94aea279bfd7dc9ce git-daemon.initd
-6d2fbf726d0a6fd49227e6f148ffbe25 git-daemon.confd"
+b23457d76ae19f7eaa477a634bbb9360 git-daemon.initd
+2258e95d389ccc6de0b5111d53d9eed6 git-daemon.confd"
diff --git a/main/git/git-daemon.confd b/main/git/git-daemon.confd
index 75b421680..6369053fc 100644
--- a/main/git/git-daemon.confd
+++ b/main/git/git-daemon.confd
@@ -10,7 +10,8 @@
# --export-all --- Exports all repositories
# --port=XXXX --- Starts in port XXXX instead of 9418
#
-GITDAEMON_OPTS="--syslog /var/git"
+GITDAEMON_REPO="/var/git"
+GITDAEMON_OPTS="--syslog --base-path=${GITDAEMON_REPO} ${GITDAEMON_REPO}"
# To run an anonymous git safely, the following user should be able to only
# read your Git repositories. It should not able able to write to anywhere on
diff --git a/main/git/git-daemon.initd b/main/git/git-daemon.initd
index c6ee19f5c..cb26b512f 100644
--- a/main/git/git-daemon.initd
+++ b/main/git/git-daemon.initd
@@ -11,11 +11,8 @@ depend() {
}
start() {
- [ -e /lib/librc.so ] || BL1_COMPAT="--name git-daemon"
ebegin "Starting git-daemon"
- start-stop-daemon --start --quiet --background \
- --pidfile ${PIDFILE} ${BL1_COMPAT} \
- --exec /usr/bin/git -- daemon \
+ /usr/bin/git daemon --detach \
--pid-file=${PIDFILE} \
--user=${GIT_USER} --group=${GIT_GROUP} \
${GITDAEMON_OPTS}