summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/firefox/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/main/firefox/APKBUILD b/main/firefox/APKBUILD
index 791b1c96e..9f1fc1dbf 100644
--- a/main/firefox/APKBUILD
+++ b/main/firefox/APKBUILD
@@ -4,7 +4,7 @@ pkgname=firefox
pkgver=26.0
_pkgver=$pkgver
_xulver=$pkgver
-pkgrel=4
+pkgrel=5
pkgdesc="firefox web browser"
url="http://www.firefox.com"
arch="all"
@@ -119,10 +119,14 @@ package() {
# launcher as symlink is broken from firefox-7.0
rm "$pkgdir"/usr/bin/firefox || return 1
+ libgl=$(scanelf -qF '#F%S' /usr/lib/libGL.so)
cat > "$pkgdir"/usr/bin/firefox << __EOF__
#!/bin/sh
-exec $_mozappdir/firefox "\$@"
+# as a workaround for libGL's initial-exec TLS we preload libgl
+# https://bugs.freedesktop.org/show_bug.cgi?id=35268
+
+LD_PRELOAD=$libgl exec $_mozappdir/firefox "\$@"
__EOF__
chmod 755 "$pkgdir"/usr/bin/firefox