summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/mesa/APKBUILD11
1 files changed, 1 insertions, 10 deletions
diff --git a/main/mesa/APKBUILD b/main/mesa/APKBUILD
index 5790b8aba..1ac866fb6 100644
--- a/main/mesa/APKBUILD
+++ b/main/mesa/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mesa
pkgver=10.5.6
-pkgrel=1
+pkgrel=2
pkgdesc="Mesa DRI OpenGL library"
url="http://www.mesa3d.org"
arch="all"
@@ -59,10 +59,6 @@ build() {
cd "$_builddir"
[ "$CLIBC" = "musl" ] && export CFLAGS="$CFLAGS -D_XOPEN_SOURCE=700"
- # set the minimum arch for x86 to prevent atmomic linker errors
- [ "$CARCH" = "x86" ] && export CFLAGS="$CFLAGS -march=i586 -mtune=generic"
-
- export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -74,7 +70,6 @@ build() {
--enable-glx-rts \
--with-gallium-drivers=r300,r600,radeonsi,nouveau,svga,swrast \
--with-dri-drivers=${_dri_drivers} \
- --enable-gallium-llvm \
--enable-llvm-shared-libs \
--enable-gallium-egl \
--with-egl-platforms=x11,drm,wayland \
@@ -93,10 +88,6 @@ build() {
|| return 1
make || return 1
-
- # check so we dont have any bind NOW
- scanelf -Rb . | grep NOW && return 1
- return 0
}
package() {