summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--core/bison/APKBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/core/bison/APKBUILD b/core/bison/APKBUILD
new file mode 100644
index 000000000..9c9e3950d
--- /dev/null
+++ b/core/bison/APKBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=bison
+pkgver=2.3
+pkgrel=4
+pkgdesc="The GNU general-purpose parser generator"
+license='GPL'
+url="http://www.gnu.org/software/bison/bison.html"
+depends='uclibc m4'
+source="ftp://ftp.gnu.org/gnu/bison/${pkgname}-${pkgver}.tar.gz"
+subpackages="$pkgname-doc"
+splitfuncs="doc"
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ ./configure --prefix=/usr --datadir=/usr/share
+ make || return 1
+ make DESTDIR=${startdir}/pkg install
+}
+
+md5sums='22327efdd5080e2b1acb6e560a04b43a bison-2.3.tar.gz'