summaryrefslogtreecommitdiffstats
path: root/main/apache2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/apache2/APKBUILD')
-rw-r--r--main/apache2/APKBUILD47
1 files changed, 22 insertions, 25 deletions
diff --git a/main/apache2/APKBUILD b/main/apache2/APKBUILD
index d85d1a29d..8b5708d2d 100644
--- a/main/apache2/APKBUILD
+++ b/main/apache2/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apache2
pkgver=2.2.17
-pkgrel=0
+pkgrel=1
pkgdesc="A high performance Unix-based HTTP server"
url="http://httpd.apache.org/"
license="APACHE"
@@ -85,29 +85,26 @@ _buildmpm() {
build () {
local mpm
- # build prefork with everything
- _buildmpm prefork \
- --enable-mods-shared=all \
- --enable-ssl --with-ssl \
- --enable-proxy \
- --enable-cache \
- --enable-disk-cache \
- --enable-mem-cache \
- --enable-file-cache \
- --enable-ldap --enable-authnz-ldap \
- --enable-cgid \
- --enable-authn-anon --enable-authn-alias \
- --disable-imagemap \
- --enable-proxy-connect \
- --enable-proxy-http \
- --enable-proxy-ftp \
- --enable-deflate \
- --enable-dbd \
- || return 1
-
- #build the alternative mpms, but without modules
- for mpm in worker itk; do
- _buildmpm $mpm --enable-modules=none
+ #build the mpms
+ for mpm in prefork worker itk; do
+ _buildmpm $mpm \
+ --enable-mods-shared=all \
+ --enable-ssl --with-ssl \
+ --enable-proxy \
+ --enable-cache \
+ --enable-disk-cache \
+ --enable-mem-cache \
+ --enable-file-cache \
+ --enable-ldap --enable-authnz-ldap \
+ --enable-cgid \
+ --enable-authn-anon --enable-authn-alias \
+ --disable-imagemap \
+ --enable-proxy-connect \
+ --enable-proxy-http \
+ --enable-proxy-ftp \
+ --enable-deflate \
+ --enable-dbd \
+ || return 1
done
}
@@ -191,7 +188,7 @@ d9667fcd2ffecc63e446edd4d6666731 10-nice.patch
e322b5211e49511cac6e40c86af1b1da apache2.confd
75fe4138b98fcffd01b8c8c077b944f3 apache2.logrotate
0261136ff734c3ae8dcf878a46ed5830 apache2.initd
-1dfc079be3fec873b67bca19b60c56b1 httpd.conf
+2df3891a45abcdc4083a2699ff7f26fc httpd.conf
5d0d024ca43571b863874ab871b2c109 ssl.conf
b70fe826486043e3953cfe21f9e6fa16 ldap.conf
c66ff5f70260d5266e6803a59b39bd7f alpine.layout"