summaryrefslogtreecommitdiffstats
path: root/main/ccache/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/ccache/APKBUILD')
-rw-r--r--main/ccache/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/main/ccache/APKBUILD b/main/ccache/APKBUILD
index 2848bb64d..b7eb252eb 100644
--- a/main/ccache/APKBUILD
+++ b/main/ccache/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ccache
-pkgver=2.4
-pkgrel=1
+pkgver=3.0
+pkgrel=0
pkgdesc="ccache is a compiler cache"
url="http://ccache.samba.org/"
license="GPL"
@@ -15,6 +15,10 @@ build ()
cd "$srcdir"/$pkgname-$pkgver
./configure --prefix=/usr
make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
install -Dm 755 ccache "$pkgdir"/usr/bin/ccache
install -Dm 644 ccache.1 "$pkgdir"/usr/share/man/man1/ccache.1
mkdir -p "$pkgdir"/usr/lib/ccache/bin
@@ -29,4 +33,4 @@ build ()
ln -sf /usr/bin/ccache "$pkgdir"/usr/lib/ccache/bin/${CHOST}-cpp
ln -sf /usr/bin/ccache "$pkgdir"/usr/lib/ccache/bin/${CHOST}-c++
}
-md5sums="73c1ed1e767c1752dd0f548ec1e66ce7 ccache-2.4.tar.gz"
+md5sums="98145b8ad69a96bf1abf9a52d550e507 ccache-3.0.tar.gz"