summaryrefslogtreecommitdiffstats
path: root/main/dahdi-linux/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/dahdi-linux/APKBUILD')
-rw-r--r--main/dahdi-linux/APKBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/main/dahdi-linux/APKBUILD b/main/dahdi-linux/APKBUILD
index 394432bef..05950dcd8 100644
--- a/main/dahdi-linux/APKBUILD
+++ b/main/dahdi-linux/APKBUILD
@@ -9,12 +9,11 @@ url="http://www.asterisk.org"
arch="noarch"
license="GPL"
depends=
-# we need wget and tar because make install downloads firmware and uses fancy
-# options for tar and wget.
-makedepends="wget tar"
+makedepends=
install=
subpackages="$pkgname-dev"
-source="http://downloads.digium.com/pub/telephony/dahdi-linux/releases/$pkgname-$pkgver.tar.gz"
+source="http://downloads.digium.com/pub/telephony/dahdi-linux/releases/$pkgname-$pkgver.tar.gz
+ wget-tar.patch"
# We online install the firmwares in this package since those are common for all
# kernel flavors. We also install the headers for the -dev package.
@@ -22,10 +21,10 @@ source="http://downloads.digium.com/pub/telephony/dahdi-linux/releases/$pkgname-
# The kernel drivers themselves are built from separate build recipe.
prepare() {
cd "$srcdir"/$pkgname-$pkgver
- for i in ../*.patch ../*.diff; do
- [ -f "$i" ] || continue
- msg "Applying $i"
- patch -p1 < $i || return 1;
+ for i in $source; do
+ case $i in
+ *.patch|*.diff) patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
done
}
@@ -35,8 +34,9 @@ build() {
package() {
cd "$srcdir"/$pkgname-$pkgver
- make DESTDIR="$pkgdir" HOTPLUG_FIRMWARE=yes \
+ make -j1 DESTDIR="$pkgdir" HOTPLUG_FIRMWARE=yes \
install-include install-firmware
}
-md5sums="037afa01dfde872c6b4864699483e199 dahdi-linux-2.5.0.2.tar.gz"
+md5sums="037afa01dfde872c6b4864699483e199 dahdi-linux-2.5.0.2.tar.gz
+d72ac3aab69c427d69f657287c5d8475 wget-tar.patch"