summaryrefslogtreecommitdiffstats
path: root/main/firefox/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/firefox/APKBUILD')
-rw-r--r--main/firefox/APKBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/main/firefox/APKBUILD b/main/firefox/APKBUILD
index 533fc65eb..f28130749 100644
--- a/main/firefox/APKBUILD
+++ b/main/firefox/APKBUILD
@@ -4,7 +4,7 @@ pkgname=firefox
pkgver=24.0
_pkgver=$pkgver
_xulver=$pkgver
-pkgrel=0
+pkgrel=1
pkgdesc="firefox web browser"
url="http://www.firefox.com"
arch="all"
@@ -56,8 +56,6 @@ source="ftp://ftp.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgve
firefox.desktop
firefox-safe.desktop"
-options="!strip"
-
_builddir="${srcdir}/mozilla-release"
_mozappdir=/usr/lib/firefox-$pkgver
@@ -76,8 +74,10 @@ prepare() {
sed -e "s/#${CLIBC}#//g" -i .mozconfig
echo "ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)" >> .mozconfig
- echo "ac_add_options --enable-debug-symbols" >> .mozconfig
- echo "ac_add_options --disable-install-strip" >>.mozconfig
+ if [ -n "$DEBUG" ]; then
+ echo "ac_add_options --enable-debug-symbols" >> .mozconfig
+ echo "ac_add_options --disable-install-strip" >>.mozconfig
+ fi
}
build() {