summaryrefslogtreecommitdiffstats
path: root/main/fixesproto
diff options
context:
space:
mode:
Diffstat (limited to 'main/fixesproto')
-rw-r--r--main/fixesproto/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/main/fixesproto/APKBUILD b/main/fixesproto/APKBUILD
index 65ccb3849..322d2bd86 100644
--- a/main/fixesproto/APKBUILD
+++ b/main/fixesproto/APKBUILD
@@ -10,8 +10,15 @@ depends="xextproto"
makedepends=""
source="http://xorg.freedesktop.org/releases/individual/proto/$pkgname-$pkgver.tar.bz2"
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \