summaryrefslogtreecommitdiffstats
path: root/main/flashrom
diff options
context:
space:
mode:
Diffstat (limited to 'main/flashrom')
-rw-r--r--main/flashrom/APKBUILD32
-rwxr-xr-xmain/flashrom/flashrom.post-install15
2 files changed, 47 insertions, 0 deletions
diff --git a/main/flashrom/APKBUILD b/main/flashrom/APKBUILD
new file mode 100644
index 000000000..7864cd6a2
--- /dev/null
+++ b/main/flashrom/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor:
+# Maintainer: Nathan Angelacos <nangel@alpinelinux.org>
+pkgname=flashrom
+pkgver=0.9.2
+pkgrel=1
+pkgdesc="A utility for identifying, reading, writing, verifying and erasing flash chips"
+url="http://www.flashrom.org/Flashrom"
+license="GPL"
+depends=dmidecode
+makedepends=pciutils-dev
+subpackages="$pkgname-doc"
+install="$pkgname.post-install"
+source="http://qa.coreboot.org/releases/flashrom-0.9.2.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ make PREFIX=/usr/ || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make PREFIX="$pkgdir/usr/" install
+}
+
+md5sums="21751b4ea93c5a82c725adae7b63014a flashrom-0.9.2.tar.bz2"
diff --git a/main/flashrom/flashrom.post-install b/main/flashrom/flashrom.post-install
new file mode 100755
index 000000000..b7919f5fd
--- /dev/null
+++ b/main/flashrom/flashrom.post-install
@@ -0,0 +1,15 @@
+#!/bin/sh
+if [ -e /proc/sys/kernel/grsecurity/ ]; then
+cat - <<EOF
+
+ ************[ flashrom package installation notice ]****************
+
+ You appear to be running a grsec enabled kernel.
+ flashrom needs write access to /dev/mem and will likely not work
+
+ *********************************************************************
+
+EOF
+fi
+exit 0
+