summaryrefslogtreecommitdiffstats
path: root/main/gcc/gcc-4.2.0-cc1-no-stack-protector.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/gcc/gcc-4.2.0-cc1-no-stack-protector.patch')
-rw-r--r--main/gcc/gcc-4.2.0-cc1-no-stack-protector.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/main/gcc/gcc-4.2.0-cc1-no-stack-protector.patch b/main/gcc/gcc-4.2.0-cc1-no-stack-protector.patch
new file mode 100644
index 000000000..cc80d1bc7
--- /dev/null
+++ b/main/gcc/gcc-4.2.0-cc1-no-stack-protector.patch
@@ -0,0 +1,11 @@
+--- a/gcc/Makefile.in.orig 2007-05-20 14:44:14.000000000 +0200
++++ b/gcc/Makefile.in 2007-05-20 14:44:27.000000000 +0200
+@@ -2641,7 +2641,7 @@
+ output.h $(INSN_ATTR_H) $(SYSTEM_H) toplev.h $(TARGET_H) libfuncs.h \
+ $(TARGET_DEF_H) $(FUNCTION_H) $(SCHED_INT_H) $(TM_P_H) $(EXPR_H) \
+ langhooks.h $(GGC_H) $(OPTABS_H) $(REAL_H) tm-constrs.h
+- $(CC) -c $(ALL_CFLAGS) $(ALL_CPPFLAGS) \
++ $(CC) -c $(ALL_CFLAGS) -fno-stack-protector $(ALL_CPPFLAGS) \
+ $(out_file) $(OUTPUT_OPTION)
+
+ # Build auxiliary files that support ecoff format.