summaryrefslogtreecommitdiffstats
path: root/main/gtk-doc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/gtk-doc/APKBUILD')
-rw-r--r--main/gtk-doc/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/main/gtk-doc/APKBUILD b/main/gtk-doc/APKBUILD
index 1c70f5b7e..34ede062c 100644
--- a/main/gtk-doc/APKBUILD
+++ b/main/gtk-doc/APKBUILD
@@ -10,8 +10,15 @@ depends="docbook-xsl gnome-doc-utils perl pkgconfig python"
makedepends="rarian-dev py-libxml2 gettext itstool"
source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz"
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \