summaryrefslogtreecommitdiffstats
path: root/main/guile/strtol_l.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/guile/strtol_l.patch')
-rw-r--r--main/guile/strtol_l.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/main/guile/strtol_l.patch b/main/guile/strtol_l.patch
new file mode 100644
index 000000000..61f4f331e
--- /dev/null
+++ b/main/guile/strtol_l.patch
@@ -0,0 +1,20 @@
+We dont have strtol_l on musl so the missing configure.ac check is not
+a problem for us. By skipping it we also avoid regenerating configure
+script.
+
+diff --git a/libguile/i18n.c b/libguile/i18n.c
+index f0e3443..17e9eca 100644
+--- a/libguile/i18n.c
++++ b/libguile/i18n.c
+@@ -1373,7 +1373,7 @@ SCM_DEFINE (scm_locale_string_to_integer, "locale-string->integer",
+
+ if (c_locale != NULL)
+ {
+-#ifdef USE_GNU_LOCALE_API
++#if defined(USE_GNU_LOCALE_API) && defined(HAVE_STRTOL_L)
+ c_result = strtol_l (c_str, &c_endptr, c_base, c_locale);
+ #else
+ RUN_IN_LOCALE_SECTION (c_locale,
+--
+2.4.3
+