summaryrefslogtreecommitdiffstats
path: root/main/libc0.9.32/0001-ntpl-fix-static-linking-by-not-leaking-SSP_ALL_CFLAG.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/libc0.9.32/0001-ntpl-fix-static-linking-by-not-leaking-SSP_ALL_CFLAG.patch')
-rw-r--r--main/libc0.9.32/0001-ntpl-fix-static-linking-by-not-leaking-SSP_ALL_CFLAG.patch200
1 files changed, 200 insertions, 0 deletions
diff --git a/main/libc0.9.32/0001-ntpl-fix-static-linking-by-not-leaking-SSP_ALL_CFLAG.patch b/main/libc0.9.32/0001-ntpl-fix-static-linking-by-not-leaking-SSP_ALL_CFLAG.patch
new file mode 100644
index 000000000..83e95e082
--- /dev/null
+++ b/main/libc0.9.32/0001-ntpl-fix-static-linking-by-not-leaking-SSP_ALL_CFLAG.patch
@@ -0,0 +1,200 @@
+From bbef1fa203ecb2ab02fa5bb25dc4ab9a708b7dcb Mon Sep 17 00:00:00 2001
+From: Natanael Copa <natanael.copa@gmail.com>
+Date: Thu, 11 Nov 2010 07:32:55 +0000
+Subject: [PATCH] ntpl: fix static linking by not leaking SSP_ALL_CFLAGS
+
+The SSP_ALL_CFLAGS in nptl arch CFLAGS leaks out and forces things
+like dl-support.c, brk.c, sbrk.c memcpy, etc to be built with
+-fstack-protector-all. This is bad when linking statically since
+initializing TLS will call those functions before SSP is initialized.
+
+The libpthread itself will still be built with -fstack-protector-all
+due to CFLAGS-nptl has SSP_ALL_CFLAGS in libpthread/nptl/Makefile.in
+
+Thanks to Timo Teras for helping with this.
+
+Signed-off-by: Natanael Copa <natanael.copa@gmail.com>
+---
+ libpthread/nptl/sysdeps/arm/Makefile.arch | 1 -
+ libpthread/nptl/sysdeps/generic/Makefile.in | 2 --
+ libpthread/nptl/sysdeps/i386/Makefile.arch | 1 -
+ libpthread/nptl/sysdeps/mips/Makefile.arch | 1 -
+ libpthread/nptl/sysdeps/powerpc/Makefile.arch | 1 -
+ libpthread/nptl/sysdeps/sh/Makefile.arch | 1 -
+ libpthread/nptl/sysdeps/sparc/Makefile.arch | 1 -
+ .../nptl/sysdeps/unix/sysv/linux/arm/Makefile.arch | 1 -
+ .../sysdeps/unix/sysv/linux/i386/Makefile.arch | 1 -
+ .../sysdeps/unix/sysv/linux/mips/Makefile.arch | 1 -
+ .../sysdeps/unix/sysv/linux/powerpc/Makefile.arch | 1 -
+ .../nptl/sysdeps/unix/sysv/linux/sh/Makefile.arch | 1 -
+ .../sysdeps/unix/sysv/linux/sparc/Makefile.arch | 1 -
+ .../sysdeps/unix/sysv/linux/x86_64/Makefile.arch | 1 -
+ libpthread/nptl/sysdeps/x86_64/Makefile.arch | 1 -
+ 15 files changed, 0 insertions(+), 16 deletions(-)
+
+diff --git a/libpthread/nptl/sysdeps/arm/Makefile.arch b/libpthread/nptl/sysdeps/arm/Makefile.arch
+index b7a9295..a8bc1aa 100644
+--- a/libpthread/nptl/sysdeps/arm/Makefile.arch
++++ b/libpthread/nptl/sysdeps/arm/Makefile.arch
+@@ -15,4 +15,3 @@ ASFLAGS-pthread_spin_lock.S = -DNOT_IN_libc -DIS_IN_libpthread
+ ASFLAGS-pthread_spin_trylock.S = -DNOT_IN_libc -DIS_IN_libpthread
+ ASFLAGS-aeabi_read_tp.S = -DNOT_IN_libc=1
+
+-CFLAGS-arm = $(SSP_ALL_CFLAGS)
+diff --git a/libpthread/nptl/sysdeps/generic/Makefile.in b/libpthread/nptl/sysdeps/generic/Makefile.in
+index 890fe05..eb656ee 100644
+--- a/libpthread/nptl/sysdeps/generic/Makefile.in
++++ b/libpthread/nptl/sysdeps/generic/Makefile.in
+@@ -19,8 +19,6 @@ libpthread_generic_libc_a_OBJS = $(libpthread_generic_libc_a_COBJ)
+ libpthread_ld_tls_CSRC = dl-tls.c
+ libpthread_ld_tls_COBJ = $(patsubst %.c,$(libpthread_generic_OUT)/%.o,$(libpthread_ld_tls_CSRC))
+
+-CFLAGS-generic = $(SSP_ALL_CFLAGS)
+-
+ objclean-y += CLEAN_libpthread/nptl/sysdeps/generic
+
+ CLEAN_libpthread/nptl/sysdeps/generic:
+diff --git a/libpthread/nptl/sysdeps/i386/Makefile.arch b/libpthread/nptl/sysdeps/i386/Makefile.arch
+index 89962f7..9572303 100644
+--- a/libpthread/nptl/sysdeps/i386/Makefile.arch
++++ b/libpthread/nptl/sysdeps/i386/Makefile.arch
+@@ -8,4 +8,3 @@
+ CFLAGS-pthread_spin_lock.c += -D_GNU_SOURCE
+ CFLAGS-pthread_create.c += -mpreferred-stack-boundary=4
+
+-CFLAGS-i386 = $(SSP_ALL_CFLAGS)
+diff --git a/libpthread/nptl/sysdeps/mips/Makefile.arch b/libpthread/nptl/sysdeps/mips/Makefile.arch
+index 6085ec8..2762a2f 100644
+--- a/libpthread/nptl/sysdeps/mips/Makefile.arch
++++ b/libpthread/nptl/sysdeps/mips/Makefile.arch
+@@ -15,4 +15,3 @@ ASFLAGS-nptl-sysdep.S = -DNOT_IN_libc -DIS_IN_libpthread \
+
+ libc_arch_a_CSRC = libc-tls.c
+
+-CFLAGS-mips = $(SSP_ALL_CFLAGS)
+diff --git a/libpthread/nptl/sysdeps/powerpc/Makefile.arch b/libpthread/nptl/sysdeps/powerpc/Makefile.arch
+index edf3f4b..18ddc28 100644
+--- a/libpthread/nptl/sysdeps/powerpc/Makefile.arch
++++ b/libpthread/nptl/sysdeps/powerpc/Makefile.arch
+@@ -5,4 +5,3 @@
+ # Licensed under the LGPL v2.1, see the file COPYING.LIB in this tarball.
+ #
+
+-CFLAGS-powerpc = $(SSP_ALL_CFLAGS)
+diff --git a/libpthread/nptl/sysdeps/sh/Makefile.arch b/libpthread/nptl/sysdeps/sh/Makefile.arch
+index eb4db68..3cb58ec 100644
+--- a/libpthread/nptl/sysdeps/sh/Makefile.arch
++++ b/libpthread/nptl/sysdeps/sh/Makefile.arch
+@@ -10,5 +10,4 @@ ASFLAGS-pthread_spin_trylock.S = -DNOT_IN_libc -DIS_IN_libpthread
+
+ CFLAGS-pthread_spin_lock.c += -D_GNU_SOURCE
+
+-CFLAGS-sh = $(SSP_ALL_CFLAGS)
+
+diff --git a/libpthread/nptl/sysdeps/sparc/Makefile.arch b/libpthread/nptl/sysdeps/sparc/Makefile.arch
+index 4494935..52ac6db 100644
+--- a/libpthread/nptl/sysdeps/sparc/Makefile.arch
++++ b/libpthread/nptl/sysdeps/sparc/Makefile.arch
+@@ -8,5 +8,4 @@ subdirs += libpthread/nptl/sysdeps/$(TARGET_ARCH)/$(TARGET_SUBARCH)/sparv9
+
+ CFLAGS-pthread_spin_lock.c += -D_GNU_SOURCE
+
+-CFLAGS-sparc = $(SSP_ALL_CFLAGS)
+
+diff --git a/libpthread/nptl/sysdeps/unix/sysv/linux/arm/Makefile.arch b/libpthread/nptl/sysdeps/unix/sysv/linux/arm/Makefile.arch
+index 2385d8d..329d8a9 100644
+--- a/libpthread/nptl/sysdeps/unix/sysv/linux/arm/Makefile.arch
++++ b/libpthread/nptl/sysdeps/unix/sysv/linux/arm/Makefile.arch
+@@ -14,7 +14,6 @@ libc_linux_arch_CSRC = fork.c libc-lowlevellock.c
+ libc_linux_arch_SSRC = clone.S vfork.S
+ libc_linux_arch_SSRC-OMIT = waitpid.S
+
+-CFLAGS += $(SSP_ALL_CFLAGS)
+
+ CFLAGS-pthread_once.c = -DNOT_IN_libc -DIS_IN_libpthread
+ CFLAGS-pt-__syscall_rt_sigaction.c = -DNOT_IN_libc -DIS_IN_libpthread
+diff --git a/libpthread/nptl/sysdeps/unix/sysv/linux/i386/Makefile.arch b/libpthread/nptl/sysdeps/unix/sysv/linux/i386/Makefile.arch
+index 1348f4d..9a34595 100644
+--- a/libpthread/nptl/sysdeps/unix/sysv/linux/i386/Makefile.arch
++++ b/libpthread/nptl/sysdeps/unix/sysv/linux/i386/Makefile.arch
+@@ -12,7 +12,6 @@ libc_linux_arch_CSRC = fork.c
+ libc_linux_arch_SSRC = clone.S vfork.S
+
+ ASFLAGS += -DUSE___THREAD
+-CFLAGS += $(SSP_ALL_CFLAGS)
+
+ CFLAGS-pt-__syscall_error.c = -DNOT_IN_libc -DIS_IN_libpthread
+ ASFLAGS-pt-vfork.S = -DNOT_IN_libc -DIS_IN_libpthread -D_LIBC_REENTRANT
+diff --git a/libpthread/nptl/sysdeps/unix/sysv/linux/mips/Makefile.arch b/libpthread/nptl/sysdeps/unix/sysv/linux/mips/Makefile.arch
+index 2ff3095..84fe17e 100644
+--- a/libpthread/nptl/sysdeps/unix/sysv/linux/mips/Makefile.arch
++++ b/libpthread/nptl/sysdeps/unix/sysv/linux/mips/Makefile.arch
+@@ -12,7 +12,6 @@ libc_linux_arch_CSRC = fork.c
+ libc_linux_arch_SSRC = clone.S vfork.S
+
+ ASFLAGS += -DUSE___THREAD
+-CFLAGS += $(SSP_ALL_CFLAGS)
+
+ CFLAGS-OMIT-fork.c = -DNOT_IN_libc -DIS_IN_libpthread
+ ifeq ($(UCLIBC_HAS_STDIO_FUTEXES),y)
+diff --git a/libpthread/nptl/sysdeps/unix/sysv/linux/powerpc/Makefile.arch b/libpthread/nptl/sysdeps/unix/sysv/linux/powerpc/Makefile.arch
+index ee75cdb..8581aea 100644
+--- a/libpthread/nptl/sysdeps/unix/sysv/linux/powerpc/Makefile.arch
++++ b/libpthread/nptl/sysdeps/unix/sysv/linux/powerpc/Makefile.arch
+@@ -15,7 +15,6 @@ libc_linux_arch_SSRC = clone.S vfork.S
+ librt_linux_arch_CSRC = pt-__syscall_error.c
+
+ ASFLAGS += -DUSE___THREAD
+-CFLAGS += $(SSP_ALL_CFLAGS)
+
+ CFLAGS-pthread_once.c = -DNOT_IN_libc -DIS_IN_libpthread
+ CFLAGS-lowlevellock.c = -DNOT_IN_libc -DIS_IN_libpthread
+diff --git a/libpthread/nptl/sysdeps/unix/sysv/linux/sh/Makefile.arch b/libpthread/nptl/sysdeps/unix/sysv/linux/sh/Makefile.arch
+index 5ac6724..a8249e0 100644
+--- a/libpthread/nptl/sysdeps/unix/sysv/linux/sh/Makefile.arch
++++ b/libpthread/nptl/sysdeps/unix/sysv/linux/sh/Makefile.arch
+@@ -16,7 +16,6 @@ libc_linux_arch_CSRC = fork.c
+ libc_linux_arch_SSRC = libc-lowlevellock.S clone.S vfork.S
+
+ ASFLAGS += -DUSE___THREAD
+-CFLAGS += $(SSP_ALL_CFLAGS)
+
+ ASFLAGS-pt-vfork.S = -DNOT_IN_libc -DIS_IN_libpthread -D_LIBC_REENTRANT
+ ASFLAGS-pthread_once.S = -D_LIBC_REENTRANT
+diff --git a/libpthread/nptl/sysdeps/unix/sysv/linux/sparc/Makefile.arch b/libpthread/nptl/sysdeps/unix/sysv/linux/sparc/Makefile.arch
+index d634894..88ca01a 100644
+--- a/libpthread/nptl/sysdeps/unix/sysv/linux/sparc/Makefile.arch
++++ b/libpthread/nptl/sysdeps/unix/sysv/linux/sparc/Makefile.arch
+@@ -13,7 +13,6 @@ libc_linux_arch_CSRC = fork.c libc-lowlevellock.c
+ libc_linux_arch_SSRC = clone.S vfork.S
+
+ ASFLAGS += -DUSE___THREAD
+-CFLAGS += $(SSP_ALL_CFLAGS)
+
+ ASFLAGS-pt-vfork.S = -DNOT_IN_libc -DIS_IN_libpthread -D_LIBC_REENTRANT
+ CFLAGS-pthread_once.c = -DNOT_IN_libc -DIS_IN_libpthread
+diff --git a/libpthread/nptl/sysdeps/unix/sysv/linux/x86_64/Makefile.arch b/libpthread/nptl/sysdeps/unix/sysv/linux/x86_64/Makefile.arch
+index 2ec3383..71df986 100644
+--- a/libpthread/nptl/sysdeps/unix/sysv/linux/x86_64/Makefile.arch
++++ b/libpthread/nptl/sysdeps/unix/sysv/linux/x86_64/Makefile.arch
+@@ -19,7 +19,6 @@ libc_linux_arch_SSRC-OMIT = waitpid.S
+ librt_linux_arch_SSRC = librt-cancellation.S
+
+ ASFLAGS += -DUSE___THREAD
+-CFLAGS += $(SSP_ALL_CFLAGS)
+
+ CFLAGS-pt-__syscall_error.c = -DNOT_IN_libc -DIS_IN_libpthread
+ ASFLAGS-pt-vfork.S = -DNOT_IN_libc -DIS_IN_libpthread -D_LIBC_REENTRANT
+diff --git a/libpthread/nptl/sysdeps/x86_64/Makefile.arch b/libpthread/nptl/sysdeps/x86_64/Makefile.arch
+index 7a955ff..cf6f1c2 100644
+--- a/libpthread/nptl/sysdeps/x86_64/Makefile.arch
++++ b/libpthread/nptl/sysdeps/x86_64/Makefile.arch
+@@ -7,5 +7,4 @@
+
+ CFLAGS-pthread_spin_lock.c += -D_GNU_SOURCE
+
+-CFLAGS-x86_64 = $(SSP_ALL_CFLAGS)
+
+--
+1.7.3.2
+