summaryrefslogtreecommitdiffstats
path: root/main/libc0.9.32/arm-nptl-tls.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/libc0.9.32/arm-nptl-tls.patch')
-rw-r--r--main/libc0.9.32/arm-nptl-tls.patch69
1 files changed, 0 insertions, 69 deletions
diff --git a/main/libc0.9.32/arm-nptl-tls.patch b/main/libc0.9.32/arm-nptl-tls.patch
deleted file mode 100644
index 44a038624..000000000
--- a/main/libc0.9.32/arm-nptl-tls.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From 565b8d14a1dc2ce1a9c4110232e1abf88f0572ed Mon Sep 17 00:00:00 2001
-From: William Pitcock <nenolod@dereferenced.org>
-Date: Fri, 14 Jan 2011 18:17:24 -0600
-Subject: [PATCH] nptl: fix TLS support on arm
-
-Signed-off-by: William Pitcock <nenolod@dereferenced.org>
----
- libpthread/nptl/sysdeps/arm/Makefile.arch | 2 +
- libpthread/nptl/sysdeps/arm/libc-tls.c | 38 +++++++++++++++++++++++++++++
- 2 files changed, 40 insertions(+), 0 deletions(-)
- create mode 100644 libpthread/nptl/sysdeps/arm/libc-tls.c
-
-diff --git a/libpthread/nptl/sysdeps/arm/Makefile.arch b/libpthread/nptl/sysdeps/arm/Makefile.arch
-index a8bc1aa..d463253 100644
---- a/libpthread/nptl/sysdeps/arm/Makefile.arch
-+++ b/libpthread/nptl/sysdeps/arm/Makefile.arch
-@@ -15,3 +15,5 @@ ASFLAGS-pthread_spin_lock.S = -DNOT_IN_libc -DIS_IN_libpthread
- ASFLAGS-pthread_spin_trylock.S = -DNOT_IN_libc -DIS_IN_libpthread
- ASFLAGS-aeabi_read_tp.S = -DNOT_IN_libc=1
-
-+libc_arch_a_CSRC = libc-tls.c
-+
-diff --git a/libpthread/nptl/sysdeps/arm/libc-tls.c b/libpthread/nptl/sysdeps/arm/libc-tls.c
-new file mode 100644
-index 0000000..a9e6d4f
---- /dev/null
-+++ b/libpthread/nptl/sysdeps/arm/libc-tls.c
-@@ -0,0 +1,38 @@
-+/* Thread-local storage handling in the ELF dynamic linker. MIPS version.
-+ Copyright (C) 2005 Free Software Foundation, Inc.
-+ This file is part of the GNU C Library.
-+
-+ The GNU C Library is free software; you can redistribute it and/or
-+ modify it under the terms of the GNU Lesser General Public
-+ License as published by the Free Software Foundation; either
-+ version 2.1 of the License, or (at your option) any later version.
-+
-+ The GNU C Library is distributed in the hope that it will be useful,
-+ but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+ Lesser General Public License for more details.
-+
-+ You should have received a copy of the GNU Lesser General Public
-+ License along with the GNU C Library; if not, write to the Free
-+ Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-+ 02111-1307 USA. */
-+
-+#include <sysdeps/generic/libc-tls.c>
-+#include <dl-tls.h>
-+
-+#if USE_TLS
-+
-+/* On ARM, linker optimizations are not required, so __tls_get_addr
-+ can be called even in statically linked binaries. In this case module
-+ must be always 1 and PT_TLS segment exist in the binary, otherwise it
-+ would not link. */
-+
-+void *
-+__tls_get_addr (tls_index *ti)
-+{
-+ dtv_t *dtv = THREAD_DTV ();
-+ return (char *) dtv[1].pointer.val + ti->ti_offset;
-+}
-+
-+#endif
-+
---
-1.7.3.5
-