summaryrefslogtreecommitdiffstats
path: root/main/libowfat
diff options
context:
space:
mode:
Diffstat (limited to 'main/libowfat')
-rw-r--r--main/libowfat/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/main/libowfat/APKBUILD b/main/libowfat/APKBUILD
new file mode 100644
index 000000000..8e3ee0eca
--- /dev/null
+++ b/main/libowfat/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libowfat
+pkgver=0.28
+pkgrel=0
+pkgdesc="reimplementation of libdjb"
+url="http://www.fefe.de/libowfat/"
+license="GPL"
+depends=
+makedepends=
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://dl.fefe.de/libowfat-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make prefix="$pkgdir"/usr MAN3DIR="$pkgdir"/usr/share/man/man3 install
+ # buffer manpage conflicts with openssl
+ mv "$pkgdir"/usr/share/man/man3/buffer.3 \
+ "$pkgdir"/usr/share/man/man3/owfatbuffer.3
+}
+
+md5sums="6bbee9a86506419657d87123b7a6f2c1 libowfat-0.28.tar.bz2"