summaryrefslogtreecommitdiffstats
path: root/main/libvorbis/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libvorbis/APKBUILD')
-rw-r--r--main/libvorbis/APKBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/main/libvorbis/APKBUILD b/main/libvorbis/APKBUILD
index 8224b0a28..65fc02151 100644
--- a/main/libvorbis/APKBUILD
+++ b/main/libvorbis/APKBUILD
@@ -13,9 +13,15 @@ makedepends="$depends_dev"
#source="http://people.xiph.org/~giles/2008/$pkgname-$pkgver.tar.gz"
source="http://downloads.xiph.org/releases/vorbis/libvorbis-$pkgver.tar.gz"
-build ()
-{
- cd "$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
+build() {
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \