summaryrefslogtreecommitdiffstats
path: root/main/lua-zmq
diff options
context:
space:
mode:
Diffstat (limited to 'main/lua-zmq')
-rw-r--r--main/lua-zmq/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/main/lua-zmq/APKBUILD b/main/lua-zmq/APKBUILD
index a64282962..bf80a51b8 100644
--- a/main/lua-zmq/APKBUILD
+++ b/main/lua-zmq/APKBUILD
@@ -2,6 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lua-zmq
pkgver=1.1_git20121231
+_ver=${pkgver%_git*}
pkgrel=0
pkgdesc="Lua zeromq2 binding"
url="https://github.com/Neopallium/lua-zmq"
@@ -11,10 +12,10 @@ depends="lua-llthreads"
makedepends="zeromq-dev cmake lua-dev"
install=""
subpackages=
-source="saveas-http://github.com/Neopallium/lua-zmq/tarball/v1.1/$pkgname-${pkgver%_git*}.tar.gz
+source="$pkgname-$_ver.tar.gz::https://github.com/Neopallium/lua-zmq/archive/v$_ver.tar.gz
git-${pkgver##*_git}.patch"
-_builddir="$srcdir"/Neopallium-lua-zmq-5cf558e
+_builddir="$srcdir"/lua-zmq-$_ver
prepare() {
local i
@@ -39,5 +40,9 @@ package() {
make install DESTDIR="$pkgdir" || return 1
}
-md5sums="d3813c48a9e2b88426fd79604862966d lua-zmq-1.1.tar.gz
+md5sums="cb4df81b4c884bf97bf6add88fcfa58d lua-zmq-1.1.tar.gz
e568cb33eef6230454a70dddfd5d3978 git-20121231.patch"
+sha256sums="f2bdf3142b744971da4eb8bdb12020a34b62f8ba384be44d8448b4ef05ec3dcc lua-zmq-1.1.tar.gz
+9f3b2ddd87c0fd7064a317e5ed63c16c4d1999b020f3d98970f1c5962ed34354 git-20121231.patch"
+sha512sums="35d7da6215a96b80ea59b52591082473d2c54bcb9577ae95ead1235de894d5ef226b6c4e3030c327b2b146e07af6b3998d91c5b520dfb35e87c85e958069362d lua-zmq-1.1.tar.gz
+12ff90d9b01ca03f8c9f8e02e1392de839c19242570acb77d5078e4358a89dabe3df6f6b701a30b95121b35ed09a72eedd0259c34b2663e5193a963c588be64c git-20121231.patch"