summaryrefslogtreecommitdiffstats
path: root/main/lua
diff options
context:
space:
mode:
Diffstat (limited to 'main/lua')
-rw-r--r--main/lua/APKBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/main/lua/APKBUILD b/main/lua/APKBUILD
index c5b63eb93..5a3613eaf 100644
--- a/main/lua/APKBUILD
+++ b/main/lua/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lua
pkgver=5.1.4
-pkgrel=5
+pkgrel=6
pkgdesc="A powerful light-weight programming language designed for extending applications."
url="http://www.lua.org/"
license="MIT"
@@ -9,6 +9,7 @@ depends=
makedepends="readline-dev libtool"
subpackages="$pkgname-dev $pkgname-doc"
source="http://www.$pkgname.org/ftp/$pkgname-$pkgver.tar.gz
+ http://www.lua.org/ftp/patch-lua-5.1.4-2
lua-5.1-make.patch
lua-5.1-module_paths.patch
"
@@ -16,9 +17,13 @@ source="http://www.$pkgname.org/ftp/$pkgname-$pkgver.tar.gz
build ()
{
cd "$srcdir"/$pkgname-$pkgver
- for i in ../*.patch; do
- msg "Applying $i"
- patch -p1 < $i || return 1
+ for i in $source; do
+ case $i in
+ patch*|*.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
done
# correct lua versioning
@@ -46,5 +51,6 @@ package() {
install -D -m 644 doc/luac.1 "$pkgdir"/usr/share/man/man1/luac.1
}
md5sums="d0870f2de55d59c1c8419f36e8fac150 lua-5.1.4.tar.gz
+1239310e0c4a581c7831e596f95cc6cd patch-lua-5.1.4-2
0145ff6036eb6bfdab427dc8f0c3f3c0 lua-5.1-make.patch
e60ef15deefb72a5930c498f1184aced lua-5.1-module_paths.patch"