summaryrefslogtreecommitdiffstats
path: root/main/lxc/version.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/lxc/version.patch')
-rw-r--r--main/lxc/version.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/main/lxc/version.patch b/main/lxc/version.patch
new file mode 100644
index 000000000..6f61d8257
--- /dev/null
+++ b/main/lxc/version.patch
@@ -0,0 +1,17 @@
+Fix version so apk-tools understand the .so version
+(1.0.0.rc4 -> 1.0.0_rc4)
+
+diff --git a/configure.ac b/configure.ac
+index 498d69a..f52bf8c 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -8,7 +8,8 @@ m4_define([lxc_version_beta], [rc4])
+
+ m4_define([lxc_version_base], [lxc_version_major.lxc_version_minor.lxc_version_micro])
+ m4_define([lxc_version],
+- [ifelse(lxc_version_beta, [], [lxc_version_base], [lxc_version_base.lxc_version_beta])])
++ [ifelse(lxc_version_beta, [], [lxc_version_base],
++ [lxc_version_base[_]lxc_version_beta])])])
+
+ AC_INIT([lxc], [lxc_version])
+