summaryrefslogtreecommitdiffstats
path: root/main/mg/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/mg/APKBUILD')
-rw-r--r--main/mg/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/main/mg/APKBUILD b/main/mg/APKBUILD
new file mode 100644
index 000000000..bf4a9660a
--- /dev/null
+++ b/main/mg/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Lee Hinman <hinman@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=mg
+pkgver=20090107
+pkgrel=0
+pkgdesc="mg is Micro GNU/emacs, this is a portable version of the mg maintained by the OpenBSD team."
+url="http://homepage.boetes.org/software/mg"
+license="public-domain BSD"
+depends=
+makedepends="ncurses-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://homepage.boetes.org/software/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ sed -i -e '/^CFLAGS/s/-Werror//' Makefile.in
+}
+
+build() {
+ cd "$_builddir"
+ ./configure
+ make prefix=/usr mandir=/usr/share/man || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" prefix=/usr mandir=/usr/share/man install
+}
+
+md5sums="f25a139da44c3a2f760ffec531bd996e mg-20090107.tar.gz"